


	
	
	
	
	
	
	

SOLIDWORKS	2016		Learn	by	doing
Tutorial	Books

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	

Copyright@2016
This	book	may	not	be	duplicated	in	any	way	without	the	express	written	consent
of	 the	 publisher,	 except	 in	 the	 form	 of	 brief	 excerpts	 or	 quotations	 for	 the



purpose	of	 review.	The	 information	contained	herein	 is	 for	 the	personal	use	of
the	 reader	 and	 may	 not	 be	 incorporated	 in	 any	 commercial	 programs,	 other
books,	 database,	 or	 any	 kind	 of	 software	 without	 written	 consent	 of	 the
publisher.	Making	copies	of	this	book	or	any	portion	for	purpose	other	than	your
own	is	a	violation	of	copyright	laws.
	
Limit	of	Liability/Disclaimer	of	Warranty:	The	author	and	publisher	make	no
representations	or	warranties	with	respect	to	the	accuracy	or	completeness	of	the
contents	of	this	work	and	specifically	disclaim	all	warranties,	including	without
limitation	warranties	of	fitness	for	a	particular	purpose.	The	advice	and	strategies
contained	herein	may	not	be	 suitable	 for	 every	 situation.	Neither	 the	publisher
nor	the	author	shall	be	liable	for	damages	arising	here	from.
	
Trademarks:	 All	 brand	 names	 and	 product	 names	 used	 in	 this	 book	 are
trademarks,	 registered	 trademarks,	 or	 trade	 names	 of	 their	 respective	 holders.
The	 author	 and	 publisher	 are	 not	 associated	 with	 any	 product	 or	 vendor
mentioned	in	this	book.
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	



	
	
	
	
	
	

Table	of	Contents
Chapter	1:	Getting	Started

Starting	SOLIDWORKS
User	Interface

Quick	Access	Toolbar
Menu
CommandManager
Features	tab
Evaluate	tab
Sketch	tab
Assemble	tab
Drawing	Environment	tabs
Sheet	Metal	tab
FeatureManager	Design	Tree
Status	bar
View	(Heads	Up)	Toolbar
Shortcut	Menus
PropertyManager
Breadcrumbs

Mouse	Functions
Customizing	 the	CommandManager,	Shortcut	Bars,	 and
Menus

Chapter	2:	Modeling	Basics
TUTORIAL	1



Opening	a	New	Part	File
Starting	a	Sketch
Adding	Dimensions
Constructing	the	Base	Feature
Adding	an	Extruded	Feature
Adding	another	Extruded	Feature
Saving	the	Part

TUTORIAL	2
Opening	a	New	Part	File
Sketching	a	Revolve	Profile
Constructing	the	Revolved	Boss
Constructing	the	Cut	feature
Constructing	another	Cut	feature
Adding	a	Fillet
Saving	the	Part

TUTORIAL	3
Opening	a	New	Part	File
Constructing	the	Cylindrical	Feature
Constructing	Cut	feature
Saving	the	Part

TUTORIAL	4
Applying	Draft
Saving	the	Part

Chapter	3:	Assembly	Basics
TUTORIAL	1

Opening	a	New	Assembly	File
Inserting	the	Base	Component
Adding	the	second	component
Applying	Mates
Adding	the	Third	Component
Checking	the	Interference
Saving	the	Assembly
Starting	the	Main	assembly



Adding	Disc	to	the	Assembly
Placing	the	Subassembly
Adding	Constraints
Placing	the	second	instance	of	the	Subassembly
Saving	the	Assembly

TUTORIAL	2
Creating	the	Exploded	View

Creating	Explode	lines
Chapter	4:	Creating	Drawings

TUTORIAL	1
Opening	a	New	Drawing	File
Generating	the	Base	View
Creating	the	Section	View
Creating	the	Detailed	View
Creating	the	Centerline
Specifying	Dimension	Settings
Retrieving	Dimensions
Adding	additional	dimensions
Saving	the	Drawing

TUTORIAL	2
Creating	a	Custom	Sheet	Format
Starting	a	New	drawing
Generating	the	Drawing	Views

TUTORIAL	3
Creating	the	Isometric	View
Generating	the	Exploded	View
Creating	the	Bill	of	Materials
Creating	Balloons

Chapter	5:	Sketching
Creating	Rectangles
Creating	Polygons
Relations

Merge



Horizontal
Vertical
Tangent
Parallel
Perpendicular
Midpoint
Automatic	Relations
Deleting	Relations
Hiding	Relations
Sketch	Numeric	Input
Replace	Entity
Make	Path
Path	Length	Dimension
Convert	Entities
Midpoint	 line,	 Perimeter	 Circle,	 and
SketchXpert
Ellipses
Partial	Ellipse
Conic
Move	and	Rotate	Entities
Rotate	Entities
Copy	Entities
Scale	Entities
Trim	Entities
Extend	Entities
Offset	Entities
TUTORIAL	1
Sketch	Fillet
Sketch	Chamfer
Mirror	Entities
Stretch	Entities

Circular	Sketch	Pattern
3D	Sketch



Chapter	6:	Additional	Modeling	Tools
TUTORIAL	1

Constructing	the	Helix
Adding	the	Reference	Plane
Constructing	the	Sweep	feature

TUTORIAL	2
Constructing	a	Revolved	Cut
Constructing	a	Mirror	Feature

TUTORIAL	3
Creating	Sections	and	Guide	curves
Creating	another	section
Constructing	the	swept	feature
Constructing	the	Extruded	feature
Adding	Fillets
Shelling	the	Model
Adding	the	Indent	feature
Adding	Threads

TUTORIAL	4
Constructing	a	cylindrical	shell
Adding	a	Slot
Constructing	the	Axis
Constructing	the	Linear	pattern
Constructing	the	Circular	pattern

TUTORIAL	5
Constructing	the	first	feature
Constructing	the	Second	Feature
Constructing	the	third	feature
Inserting	Holes
Adding	Chamfers

TUTORIAL	6
Constructing	the	first	feature
Constructing	the	Extruded	cut
Making	the	Curve	Driven	Pattern



TUTORIAL	7
Start	a	new	part	file
Creating	the	second	feature
Adding	Cosmetic	Threads
Creating	Configurations	Table

TUTORIAL	8
Creating	the	First	Feature
Creating	the	Extruded	surface
Replacing	 the	 top	 face	 of	 the	 model	 with	 the
surface
Creating	a	Face	fillet
Creating	a	Variable	Radius	fillet
Shelling	the	Model
Creating	the	Mounting	Bosses
Creating	the	Vent	Feature

Chapter	7:	Sheet	metal	Modeling
TUTORIAL	1

Opening	a	New	File
Constructing	the	Base	Flange
Adding	an	Edge	flange
Constructing	the	Miter	Flange
Closing	the	Corners
Adding	Corner	Reliefs
Adding	a	Tab	feature
Adding	a	Jog
Unfolding	the	bends
Creating	Cuts	across	bends
Folding	the	Unfolded	bends
Performing	the	Forming	Operations
Making	the	Linear	Pattern
Adding	a	Hem
Adding	a	vent
Adding	Sheet	Metal	Gussets



Making	a	Fill	Pattern
Chapter	8:	Top-Down	Assembly

Creating	a	New	Assembly	File
Creating	a	component	in	the	Assembly
Creating	 the	 Second	 Component	 of	 the
Assembly
Creating	the	third	Component	of	the	Assembly
Adding	Bolt	Connections	to	the	assembly
Patterning	components	in	an	assembly

TUTORIAL	2
Creating	Smart	Mates
Creating	the	Limit	Mate
Creating	the	Slot	Mate

Chapter	9:	Dimensions	and	Annotations
TUTORIAL	1

Creating	a	Model	View	with	Center	Marks
Creating	Centerlines	and	Center	Marks
Editing	the	Hatch	Pattern
Applying	Dimensions
Placing	the	Datum	Feature
Placing	the	Feature	Control	Frame
Placing	the	Surface	Texture	Symbols

Additional	Exercises
Exercise	1
Exercise	2
Exercise	3
Exercise	4
Exercise	5
Exercise	6

	

	



	
	
	
	
	
	
	
	

	



INTRODUCTION

SOLIDWORKS	is	a	package	adding	a	great	value	to	enterprises.	It	offers	a	set	of
tools,	which	are	easy-to-use	to	design,	document	and	simulate	3D	models.	Using
this	 software,	 you	 can	 speed	 up	 the	 design	 process	 and	 reduce	 the	 product
development	costs.

This	book	provides	a	systematic	approach	for	users	to	learn	SOLIDWORKS.	It
is	aimed	at	new	SOLIDWORKS	users.	However,	users	of	previous	versions	of
SOLIDWORKS	 may	 also	 find	 this	 book	 useful	 for	 them	 to	 learn	 the	 new
enhancements.	This	book	guides	the	user	from	starting	a	SOLIDWORKS	2016
session	 to	 constructing	 parts,	 assemblies,	 and	 drawings.	 Each	 chapter	 has
components	explained	with	the	help	of	real	world	models.

	Scope	of	this	book

If	you	are	a	student	or	engineer	who	is	interested	to	learn	SOLIDWORKS	2016
for	mechanical	design,	then	this	book	helps	you	to	do	it	easily	and	quickly.	You
will	also	enjoy	the	learning	process	by	creating	real	world	models.	In	addition,	if
you	are	a	graphical	learner,	then	you	will	find	this	book	very	interesting.

The	topics	in	this	book	include	Getting	Started	with	SOLIDWORKS	2016,	Basic
Part	Modeling,	Creating	Assemblies,	Creating	Drawings,	Additional	Modeling
Tools,	and	Sheet	Metal	Modeling.

Chapter	1	 introduces	SOLIDWORKS.	The	user	 interface	and	 terminology	are
discussed	in	this	chapter.

Chapter	2	 takes	you	through	the	creation	of	your	first	SOLIDWORKS	model.
You	create	simple	parts.

Chapter	 3	 teaches	 you	 to	 create	 assemblies.	 It	 explains	 the	 Top-down	 and
Bottom-up	approaches	for	designing	an	assembly.	You	create	an	assembly	using
the	Bottom-up	approach.

Chapter	4	 teaches	you	 to	 create	drawings	of	 the	models	 created	 in	 the	 earlier



chapters.	 You	 will	 also	 learn	 to	 place	 exploded	 views,	 and	 part	 list	 of	 an
assembly.

Chapter	5:	In	this	chapter,	you	will	learn	sketch	tools.

Chapter	 6:	 In	 this	 chapter,	 you	will	 learn	 additional	modeling	 tools	 to	 create
complex	models.

Chapter	 7:	 introduces	 you	 to	 Sheet	Metal	 modeling.	 You	will	 create	 a	 sheet
metal	part	using	the	tools	available	in	the	Sheet	Metal	environment.

Chapter	8:	In	this	chapter,	you	will	learn	to	create	assemblies	using	Top-down
approach	and	apply	some	advanced	mates.

Chapter	9:	In	this	chapter,	you	will	learn	to	add	annotations	to	drawings.

	
	
	
	



Chapter	1:	Getting	Started

In	 this	 chapter,	 you	 will	 learn	 some	 of	 the	 most	 commonly	 used	 features	 of
SOLIDWORKS.	In	addition,	you	will	learn	about	the	user	interface.

SOLIDWORKS	 is	 a	 parametric	 and	 feature-based	 system	 that	 allows	 you	 to
create	3D	parts,	 assemblies,	 and	2D	drawings.	The	 following	 figure	 shows	 the
design	process	in	SOLIDWORKS.

In	SOLIDWORKS,	you	create	parts	by	combining	features.



Features	are	of	 two	 types:	 sketch-based	and	placed.	You	create	a	 sketch	based
feature	by	drawing	a	sketch	and	extruding,	revolving,	sweeping	along	a	path,	or
lofting	it.

You	 create	 placed	 features	 by	 simply	 placing	 them	 onto	 an	 existing	 feature.
Examples	of	placed	features	are	fillets,	chamfers,	drafts,	shells,	holes	and	so	on.



In	SOLIDWORKS,	parameters,	dimensions,	or	relations	control	everything.	For
example,	 if	 you	want	 to	 change	 the	 position	 of	 the	 hole	 shown	 in	 figure,	 you
need	to	change	the	dimension	or	relation	that	controls	its	position.

	
Starting	SOLIDWORKS
	

Click	the	Start	button	on	the	Windows	taskbar.
Click	All	apps.
Click	SOLIDWORKS	2016	>	SOLIDWORKS	2016.
Click	the	New	button;	the	Units	and	Dimension	Standard	dialog	appears.
On	the	Units	and	Dimension	Standard	dialog,	select	MMGS	(millimeter,
gram,	second)	and	ANSI	from	the	Units	and	Dimension	Standard	drop-
downs,	respectively.



Click	OK	on	the	Units	and	Dimension	Standard	drop-down
On	the	New	SOLIDWORKS	Document	dialog,	click	Part.

Click	OK	button

Notice	these	important	features	of	the	SOLIDWORKS	window.
													



User	Interface
The	following	sections	explain	various	components	of	the	user	interface.

Quick	Access	Toolbar
This	 is	 available	 at	 the	 top	 of	 the	window.	 It	 contains	 the	 tools	 such	 as	New,
Save,	Open	and	so	on.

Menu
Menu	 is	 located	 at	 the	 top	 of	 the	 window.	 You	 can	 display	 it	 by	 placing	 the
pointer	on	the	arrow	located	at	the	top	left	corner.	It	has	various	options	(menu
titles).	When	you	click	on	a	menu	title,	a	drop-down	appears.	Select	any	option
from	this	drop-down.



CommandManager
CommandManager	is	located	below	the	menu.	It	consists	of	various	tabs.	When
you	click	on	a	 tab,	a	set	of	 tools	appear.	You	can	select	 the	required	tool	from
the	tab.	The	following	sections	explain	the	CommandManager	tabs	available	in
SOLIDWORKS.

Features	tab
This	CommandManager	tab	contains	the	tools	to	create	3D	features.

Evaluate	tab
This	 CommandManager	 tab	 has	 the	 tools	 to	 measure	 the	 objects.	 It	 also	 has
analysis	tools	to	analyze	the	draft,	curvature,	surface	and	so	on.

Sketch	tab
This	tab	contains	all	the	sketch	tools.

Assemble	tab
This	CommandManager	tab	contains	the	tools	to	create	an	assembly.	This	tab	is
available	in	an	assembly	document.



Drawing	Environment	tabs
In	 the	 Drawing	 Environment,	 you	 can	 create	 orthographic	 views	 of	 the	 3D
model.	The	CommandManager	 tabs	 in	 this	environment	contain	 tools	 to	create
2D	drawings.

Sheet	Metal	tab
Use	the	tools	in	this	tab	to	create	sheet	metal	components.	Note	that	this	tab	is	no
displayed	 by	 default.	 You	 can	 display	 it	 by	 right	 clicking	 on	 anyone	 of	 the
CommandManager	tabs	and	selecting	Sheet	Metal	from	the	menu.

	
FeatureManager	Design	Tree
This	is	located	on	the	left	pane	of	the	application	window.	It	contains	the	list	of
operations	carried	in	a	SOLIDWORKS	document.



	
Status	bar
This	 is	 available	 below	 the	 graphics	 window.	 It	 displays	 status	 of	 the
SOLIDWORKS	document.	For	example,	if	you	are	drawing	a	sketch,	it	displays
Editing	sketch.

View	(Heads	Up)	Toolbar
This	is	located	at	the	top	of	the	graphics	window.	It	contains	the	tools	to	modify
the	display	of	the	model.

Shortcut	Menus
When	 you	 click	 the	 right	 mouse	 button,	 a	 shortcut	 menu	 appears.	 A	 shortcut
menu	contains	a	list	of	some	important	options	that	can	accessed	very	quickly.



PropertyManager
When	you	activate	any	tool	in	SOLIDWORKS,	the	PropertyManager	related	to
it	 appears.	 It	 consists	 of	 various	options	 that	 are	 part	 of	 the	 selected	 tool.	The
following	figure	shows	the	components	of	the	PropertyManager.



Breadcrumbs
Breadcrumbs	is	a	new	functionality	added	to	SOLIDWORKS	2016.	Whenever
you	 click	 on	 an	 item	 or	 a	 feature	 of	 the	 model	 geometry,	 the	Breadcrumbs
toolbar	appears	at	the	top	left	corner	of	the	graphics	window.	For	example,	click
on	 a	 face	 of	 the	 part	 geometry,	 as	 shown;	 the	 Selection	 Breadcrumbs	 toolbar
appears,	 as	 shown.	 On	 the	 toolbar,	 you	 can	 select	 the	 entire	 part,	 solid	 body,
feature	 or	 sketch	 related	 to	 the	 feature,	 or	 a	 face.	

Select	 the	 feature	 from	 the	Breadcrumbs	 toolbar	 and	notice	 the	options	 to	 edit
the	feature,	suppress,	hide,	zoom,	and	so	on.	You	can	hide	the	left	pane	and	use
the	Breadcrumbs	toolbar	to	edit	model	geometry.

Mouse	Functions
Various	functions	of	the	mouse	buttons	are:

Left	Mouse	button	(MB1)
You	 can	 select	 an	 object,	 tool,	 or	 option	 using	 clicking	 the	 left	mouse	 button.
When	 you	 double-click	 the	 left	 mouse	 button	 (MB1)	 on	 an	 object,	 the



dimensions	related	to	the	object	appear.	You	can	then	edit	the	dimensions	of	the
objects.

Middle	Mouse	button	(MB2)
Click	and	drag	this	button	to	rotate	the	model	view.

Right	Mouse	button	(MB3)
Click	this	button	to	open	a	shortcut	menu.	Click	and	drag	the	right	mouse	button
to	display	the

	
Customizing	 the	 CommandManager,	 Shortcut	 Bars,
and	Menus
To	customize	the	CommandManager,	shortcut	keys,	or	menus,	click	Options	>
Customize	 on	 the	Quick	Access	 Toolbar.	 On	 the	Customize	 dialog,	 use	 the
tabs	to	customize	the	CommandManager	or	menu,	or	shortcut	bars.



	
	
	
	



Chapter	2:	Modeling	Basics

This	chapter	teaches	you	to	construct	your	first	SOLIDWORKS	model.	You	will
construct	parts	of	an	Oldham	Coupling:

In	this	chapter,	you	will:
Construct	Sketches
Construct	a	base	feature
Add	another	feature	to	it
Construct	revolved	features
Construct	cylindrical	features	and
Apply	draft

	
TUTORIAL	1
This	tutorial	takes	you	through	the	creation	of	your	first	SOLIDWORKS	model.
You	construct	the	Disc	of	the	Old	ham	coupling	assembly:



Opening	a	New	Part	File
1.	 To	open	a	new	part,	click	the	New	button	on	the	Quick	Access	Toolbar.

														
2.	 On	the	New	SOLIDWORKS	Document	dialog,	click	Part,	and	then	click

OK.

Starting	a	Sketch
1.	 To	start	a	new	sketch,	click	Sketch	>	Sketch	on	the	CommandManager.

														
	

2.	 Left	click	on	the	front	plane.



	

3.	 Click	 Sketch	 >	 Circle	 on	 the	 CommandManager	 to	 start	 creating	 a
circle.

4.	 Select	the	origin	point	of	the	coordinate	system.

5.	 Move	the	pointer	away	from	the	origin	and	click	to	draw	the	circle.

6.	 Press	ESC	to	deactivate	the	tool.

Adding	Dimensions
In	 this	 section,	 you	 will	 specify	 the	 size	 of	 the	 sketched	 circle	 by	 adding
dimensions.

As	 you	 add	 dimensions,	 the	 sketch	 can	 attain	 any	 one	 of	 the	 following	 three



states:

Fully	Constrained	sketch:	In	a	fully	constrained	sketch,	the	positions	of	all	the
entities	 are	 fully	 described	 by	 dimensions,	 relations,	 or	 both.	 In	 a	 fully
constrained	sketch,	all	the	entities	are	black	color.

Under	 Constrained	 sketch:	 To	 define	 the	 geometry	 completely,	 you	 need
additional	dimensions,	 relations,	or	both.	 In	 this	 state,	you	can	drag	 the	 sketch
elements	 to	modify	 the	sketch.	An	under	constrained	sketch	element	 is	 in	blue
color.

Over	Constrained	 sketch:	 In	 this	 state,	 an	 object	 has	 conflicting	 dimensions,
relations,	or	both.	An	over	constraining	dimension	is	in	yellow	color.

1.	 Click	Sketch	>	Smart	Dimension	 on	 the	CommandManager	 to	 start
dimensioning	the	sketch.

2.	 Select	the	circle	and	click;	the	Modify	box	appears.
3.	 Type-in	100	in	the	box	and	press	Enter	on	the	keyboard.
4.	 Press	Esc	to	deactivate	the	Smart	Dimension	tool.
5.	 To	display	the	entire	circle	at	full	size	and	to	center	it	in	the	graphics	area,

use	one	of	the	following	methods:

•	On	the	View	(Heads	Up)	toolbar,	click	Zoom	to	Fit.

•	On	the	Menu	bar,	click	View	>	Modify	>	Zoom	to	Fit.

6.	 On	the	CommandManager,	click	Sketch	>	Exit	Sketch.



7.	 On	the	View	(Heads	Up)	toolbar,	click	View	Orientation.
8.	 Click	on	the	top-right	corner	of	the	View	Selector	cube.

Constructing	the	Base	Feature
You	can	call	 the	 first	 feature	of	any	part	as	a	base	 feature.	You	now	construct
this	feature	by	extruding	the	sketched	circle.

1.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
2.	 Click	on	the	sketched	circle.

3.	 On	the	Boss-Extrude	PropertyManager,	 type-in	10	 in	 the	Depth	box,	and
then	click	OK .



	 	 	 	 	 	 	 	 	 	 	 	 	 	 Notice	 the	 new	 feature,	 Boss-Extrude1,	 in	 the
FeatureManager	Design	Tree.

Adding	an	Extruded	Feature
To	 construct	 additional	 features	 on	 the	 part,	 you	 must	 draw	 sketches	 on	 the
model	faces	or	planes,	and	then	convert	them	into	features.

1.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
2.	 Click	on	the	front	face	of	the	model.
3.	 On	the	CommandManager,	click	Sketch	>	Convert	Entities .
4.	 Click	on	the	circular	edge	of	the	model	geometry.



	

5.	 On	the	Convert	Entities	PropertyManager,	click	OK .

	

6.	 On	the	CommandManager,	click	Sketch	>	Line .

7.	 Click	on	the	circular	edge	to	specify	the	first	point	of	the	line.



8.	 Move	the	pointer	towards	right.
9.	 Click	 on	 the	 other	 side	 of	 the	 circular	 edge;	 a	 line	 is	 drawn.	 In	 addition,

another	line	is	attached	to	the	pointer.

10.	 Right-click	and	select	End	chain	to	end	the	line.

11.	 Draw	another	line	below	the	previous	line.



9.														Press	Esc	to	deactivate	the	Line	tool.
10.														On	the	CommandManager,	click	Sketch	>	Display/Delete
Relations	>	Add	Relation.

12.	 Select	the	two	lines.
13.	 On	the	Add	Relations	PropertyManager,	under	the	Add	Relations	section,

click	Horizontal	to	make	the	two	lines	horizontal.
14.	 Under	 the	Add	Relations	 section,	 click	Equal	 to	make	 the	 lines	equal	 in

length.

	
15.	 Click	OK	 on	the	PropertyManager.

16.	 On	the	CommandManager,	click	Sketch	>	Smart	Dimension .
17.	 Select	the	two	horizontal	lines.
18.	 Move	the	pointer	toward	right	and	click	to	locate	the	dimension.
19.	 Type-in	12	in	the	Modify	box	and	click	OK.



	

20.	 On	the	CommandManager,	click	Sketch	>	Trim	Entities .
21.	 Click	the	Trim	to	Closest	icon	on	the	PropertyManager.

22.	 Click	on	the	arc	portions	of	the	projected	entity.

The	projected	entities	are	trimmed.



23.	 Click	OK	 on	the	PropertyManager.
24.	 On	the	top	right	corner	of	the	graphics	window,	select	Exit	Sketch.

25.	 On	the	Boss-Extrude	PropertyManager,	 type-in	10	 in	 the	Depth	box,	and
then	click	OK .

Adding	another	Extruded	Feature
1.	 Press	and	hold	the	Middle	Mouse	Button	and	drag	the	pointer	to	rotate	the

part	such	that	the	back	face	of	the	part	is	displayed.



2.	 On	the	CommandManager,	click	Sketch	>	Sketch .
3.	 Click	on	the	back	face	of	the	part.
4.	 Activate	the	Convert	Entities	 tool	and	convert	the	circular	edge	into	a

sketch	entity.

5.	 Draw	two	lines,	as	shown	below.



6.	 Press	Esc	to	deactivate	the	Line	tool.
7.	 Press	the	Ctrl	key	and	click	on	the	lines.
8.	 On	the	PropertyManager,	under	the	Add	Relations	section,	click	Vertical.
9.	 Click	Equal,	and	then	click	OK	on	the	PropertyManager.

	
10.	 Activate	the	Smart	Dimension	 tool	and	apply	a	dimension	of	12	mm

distance	between	the	vertical	lines.													



11.	 Activate	the	Trim	Entities	 tool.
12.	 Click	the	Power	Trim	icon	on	the	PropertyManager.

13.	 Click	 the	 left	mouse	button	and	drag	 the	pointer	across	 the	 right	 side	arc;
the	arc	is	trimmed.

14.	 Release	the	left	mouse	button.
15.	 Likewise,	trim	the	left	side	arc	by	dragging	the	mouse	across	it.



16.	 Click	Exit	Sketch.
17.	 Extrude	the	sketch	up	to	10	mm	depth.

To	magnify	a	model	in	the	graphics	area,	you	can	use	the	zoom	tools	available
on	 the	View	 (Heads	Up)	 toolbar	 or	View	>	Modify	menu	 or	 on	 the	Shortcut
menu.



Click	Zoom	to	Fit	 to	display	the	part	full	size	in	the	current	window.

Click	Zoom	to	Area ,	and	then	drag	the	pointer	to	construct	a	rectangle;	the
area	in	the	rectangle	zooms	to	fill	the	window.

Click	 Zoom	 In/Out ,	 and	 then	 drag	 the	 pointer.	 Dragging	 up	 zooms	 in;
dragging	down	zooms	out.

Click	on	a	face,	edge,	vertex	or	any	object,	and	then	click	Zoom	to	Selection	
on	the	Context	Toolbar.	You	will	zoom	to	the	selection.



To	move	the	part	view,	click	the	right	mouse	button	and	select	Pan .

Drag	the	part	to	move	it	around	in	the	graphics	area.

Select	Rotate	About	Scene	Floor	from	the	right-click	shortcut	menu	helps	you
to	rotate	the	view	about	axis	perpendicular	to	the	scene	floor.	After	enabling	this
option,	you	can	use	the	Roll	View	 option	to	rotate	the	view.

Saving	the	Part
1.	 Click	the	Save	 button	on	the	Quick	Access	Toolbar.
2.	 Enter	Disc	in	the	File	name	field.
3.	 Browse	 to	C:\Users\Username\Documents	 folder,	 and	 then	 create	 a	 new

folder	with	the	name	Oldham	Coupling.
4.	 Click	Save	to	save	the	file.
5.	 Click	File	>	Close.

Note:	.prt	or	.sldprt	are	the	file	extensions	for	the	files	that	are	created	in	the	Part
environment	of	SOLIDWORKS.

TUTORIAL	2
In	 this	 tutorial,	 you	 will	 construct	 a	 flange	 by	 performing	 the	 following
operations:

Constructing	revolved	feature
Constructing	cut	features
Adding	Rounds



Opening	a	New	Part	File
1.														To	open	a	new	part,	click	the	New	 button	on	the	Quick
Access	Toolbar.
2.														On	the	New	SOLIDWORKS	Document	dialog,	click	Part,
and	then	click	OK.

Sketching	a	Revolve	Profile
Now,	you	will	construct	a	sketch	for	the	revolved	feature.

1.	 On	the	CommandManager,	click	Sketch	>	Sketch .
2.	 Click	on	the	right	plane.



3.	 Activate	 the	Line	 tool	and	click	somewhere	above	 the	vertical	axis	of	 the
origin.

4.	 Move	the	pointer	upwards.	You	will	notice	that	the	Vertical	relation	symbol
appears.

5.	 Click	to	draw	a	vertical	line.

6.	 Move	 the	pointer	 toward	 left.	You	will	notice	 that	 the	Horizontal	 relation
symbol	appears.

7.	 Click	to	draw	a	horizontal	line.

8.	 Complete	the	sketch	by	constructing	the	other	lines.



9.	 On	the	CommandManager,	click	Sketch	>	Line	>	Centerline.

10.	 Draw	a	horizontal	line	passing	through	the	horizontal	axis	of	the	coordinate
system.

6.	 Activate	 the	 Smart	 Dimension	 tool	 and	 apply	 to	 two	 horizontal
dimensions.



	

7.	 Click	on	the	centerline	and	bottom	horizontal	line.

7.	 Move	the	pointer	downwards	right.	Click	to	position	the	dimension.

	

8.	 Type-in	30	in	the	Modify	box	and	click	OK.



	

9.	 Create	other	symmetric	dimensions,	as	shown.

	

10.	 Click	Exit	Sketch .

Constructing	the	Revolved	Boss
1.	 On	the	CommandManager,	click	Features	>	Revolved	Boss/Base .



2.	 On	the	Revolve	PropertyManager,	set	the	Direction1	Angle	value	to	360.

3.	 Click	OK .



Constructing	the	Cut	feature
1.	 Press	and	hold	the	Middle	Mouse	Button	and	drag	the	pointer	to	rotate	the

part.

2.	 Click	on	the	back	face	and	click	Sketch.

3.	 On	the	CommandManager,	click	Sketch	>	Rectangle	drop-down	>	Center
Rectangle.



4.	 Select	the	origin	to	define	the	center	point.

11.	 Move	the	pointer	diagonally	toward	right	and	click	to	create	the	rectangle.

5.	 Add	dimensions	to	the	sketch.

6.	 Click	Exit	Sketch.

7.	 On	the	CommandManager,	click	Features	>	Extruded	Cut .



8.	 On	the	Cut-Extrude	PropertyManager,	set	the	Depth	value	to	10	and	click
OK .

Constructing	another	Cut	feature
1.	 Press	 the	 right	 mouse	 button	 and	 drag	 the	 mouse	 to	 display	 the	 Mouse

gesture.
2.	 On	the	Mouse	gesture,	select	Front.

3.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Sketch	 	 and	 click	 on	 the
front	face.



4.	 Press	S	on	the	keyboard.
5.	 On	the	Flyout	Toolbar,	click	Rectangle.

6.	 On	the	PropertyManager,	select	Corner	Rectangle .
7.	 Specify	the	corners	of	the	rectangle.

	
8.	 On	the	CommandManager,	click	Sketch	>	Line	>	Centerline .
9.	 Draw	a	horizontal	centerline	passing	through	the	origin.
10.	 Press	the	Ctrl	key	and	click	on	the	horizontal	lines	of	the	sketch.



	
11.	 On	 the	 PropertyManager,	 under	 the	 Add	 Relations	 section,	 click

Symmetric.

12.	 Click	OK .
13.	 Add	dimensions	to	the	sketch.

	
14.	 Click	Exit	Sketch.



15.	 On	the	CommandManager,	click	Features	>	Extruded	Cut .
16.	 Click	on	the	sketch.
17.	 On	 the	 Cut-Extrude	 PropertyManager,	 under	 the	 Direction	 1	 section,

select	End	Condition	>	Through	All.

	
18.	 Click	OK	 to	construct	the	cutout.
19.	 Press	Ctrl+7	on	your	keyboard	to	change	the	view	to	isometric.

Adding	a	Fillet
1.	 Click	on	the	circular	edge	of	the	model	geometry	and	select	Fillet.



	

2.	 Enter	5	in	the	callout	attached	to	the	selected	edge.

3.	 Click	OK	 to	add	the	fillet.

To	 display	 the	 part	 in	 different	 modes,	 use	 the	 options	 on	 the	Display	 Style
menu	on	the	View	(Heads	Up)	toolbar.



Shaded	With	Edges

Shaded

Hidden	Lines	Removed

Hidden	Lines	Vissible



Wireframe

The	default	display	mode	for	parts	and	assemblies	is	Shaded	With	Edges.	You
may	change	the	display	mode	whenever	you	want.

Saving	the	Part
1.	 Click	the	Save	 button	on	the	Quick	Access	Toolbar.
2.	 Enter	Flange	in	the	File	name	field.
3.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.
4.	 Click	Save	to	save	the	file.
5.	 Click	File	>	Close.

TUTORIAL	3
In	 this	 tutorial,	 you	 will	 construct	 a	 Shaft	 by	 performing	 the	 following
operations:

Constructing	a	cylindrical	feature
Constructing	a	cut	feature

Opening	a	New	Part	File
1.	 To	open	a	new	part,	click	File	>	New	on	the	menu	bar.



2.	 On	the	New	SOLIDWORKS	Document	dialog,	click	the	Part	button.
3.	 Click	OK.

Constructing	the	Cylindrical	Feature
1.	 Activate	the	Revolved	Boss/Base	 tool	and	click	the	right	plane.
2.	 Construct	the	sketch,	as	shown	in	figure.

	

3.	 Click	Exit	Sketch .
4.	 Click	 on	 the	 bottom	 horizontal	 line	 of	 the	 sketch	 to	 define	 the	 axis	 of

rotation.

5.	 Click	OK .



Constructing	Cut	feature
1.	 Activate	the	Extruded	Cut	 tool	and	click	on	the	front	face	of	the	model

geometry.
2.	 On	the	CommandManager,	click	Sketch	>	Center	Rectangle .
3.	 Click	on	the	top	quadrant	point	of	the	circular	edge.

4.	 Move	the	pointer	away	and	click	to	construct	the	rectangle.



5.	 Add	dimensions	and	relations	to	fully	constrain	the	sketch.

	

6.	 Click	Exit	Sketch.
7.	 Click	on	the	extrude	handle	and	drag.	A	scale	appears	on	the	model.
8.	 Release	the	pointed	when	the	depth	is	set	to	55.



9.	 Click	OK .

Saving	the	Part
1.	 Click	the	Save	 button	on	the	Quick	Access	Toolbar.
2.	 Enter	Shaft	in	the	File	name	field.
3.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.

4.	 Click	Save	to	save	the	file.
5.	 Click	File	>	Close.

TUTORIAL	4
In	this	tutorial,	you	construct	a	Key	by	performing	the	following	operations:



Constructing	an	Extruded	Boss
Applying	draft

	

Constructing	Extruded	Boss
1.	 To	open	a	new	part,	click	File	>	New	on	the	menu	bar.
2.	 On	the	New	SOLIDWORKS	Document	dialog,	click	the	Part	button.
3.	 Click	OK.
4.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
5.	 Click	on	the	front	plane.
6.	 Construct	the	sketch,	as	shown	in	figure.

7.	 Click	Exit	Sketch.
8.	 On	the	Boss-Extrude	PropertyManager,	under	the	Direction	1	section,	set

End	Condition	to	Mid	Plane.
9.	 Set	the	Depth	value	to	50.
10.	 Click	OK	to	construct	the	extruded	boss.



Applying	Draft
1.	 On	the	CommandManager,	click	Features	>	Draft .

2.	 Click	on	the	front	face	of	the	model	geometry	to	define	the	neutral	plane
3.	 Click	on	the	top	face	to	define	the	draft	face.

	



4.	 Type-in	 1	 in	 the	Draft	 Angle	 box	 and	 click	 the	Reverse	 Direction	
button.

5.	 Click	OK.

Saving	the	Part
1.	 Click	the	Save	button	on	the	Quick	Access	Toolbar.

2.														Enter	Key	in	the	File	name	field.
3.	 	 	 	 	 	 	 	 	 	 	 	 	 	 Browse	 to	C:\Users\Username\Documents\Oldham
Coupling	folder.
4.														Click	Save	to	save	the	file.
5.														Click	File	>	Close.



Chapter	3:	Assembly	Basics

In	this	chapter,	you	will:

Add	Components	to	the	assembly
Apply	constraints	between	components
Create	the	exploded	view	of	the	assembly

	
TUTORIAL	1
This	 tutorial	 takes	you	 through	 the	creation	of	your	 first	 assembly.	You	create

the	Oldham	coupling	assembly:	



There	are	two	ways	to	create	an	assembly	model.

•															Top-Down	Approach
•															Bottom-Up	Approach

Top-Down	Approach
First,	you	will	start	the	assembly	document,	and	then	construct	components	in	it.
	
Bottom-Up	Approach
First,	 you	 will	 create	 the	 components,	 and	 then	 add	 them	 to	 the	 assembly
document.	In	this	tutorial,	you	will	create	an	assembly	using	this	approach.

Opening	a	New	Assembly	File
1.	 To	open	a	new	assembly,	click	New 	on	the	Quick	Access	Toolbar.
2.	 On	the	New	SOLIDWORKS	Document	dialog,	click	Assembly,	and	then

click	OK.

The	 Assembly	 window	 appears	 along	 with	 the	 Begin	 Assembly
PropertyManager	located	on	the	left	side.
Inserting	the	Base	Component
1.	 On	 the	 Begin	 Assembly	 PropertyManager,	 under	 the	 Part/Assembly	 to

Insert	section,	click	the	Browse	button.
2.	 Browse	 to	 the	 location:	 C:\Users\Username\Documents\Oldham

Coupling.
3.	 Double-click	on	Flange.	This	attaches	the	component	to	the	pointer.
4.	 Click	inside	the	graphics	window	to	position	the	component.



Adding	the	second	component
1.	 To	insert	the	second	component,	click	Assembly	>	Insert	Component	

on	the	CommandManager.
2.	 On	the	Insert	Component	PropertyManager,	click	the	Browse	button.
3.	 Browse	 to	 the	 location	 C:\Users\Username\Documents\Oldham

Coupling,	and	then	double-click	on	Shaft.
4.	 Click	inside	the	graphics	window	to	position	the	shaft.

In	 SOLIDWORKS	 2016,	 you	 can	 view	 a	 component	 in	 separate	 preview
window.	 This	 helps	 you	 to	 the	 rotate	 or	move	 component	 independently,	 and
apply	mates.	To	view	component	in	the	preview	window,	click	on	it	and	select
Component	Preview	Window .

Applying	Mates
After	adding	the	components	to	the	assembly	window,	you	have	to	apply	mates
between	 them.	 By	 applying	 mates,	 you	 establish	 real	 contact	 and	 motion
between	components.



You	can	apply	mates	between	parts	using	the	Mate	 tool.

The	following	sections	explain	some	of	 the	assembly	mates	that	you	can	apply
using	the	Mate	tool.

Coincident:	Using	 this	mate,	 you	 can	 align	 two	 faces	 such	 that	 they	will
point	in	the	same	direction.

On	 the	 context	 toolbar,	 click	 Flip	 Mate	 Alignment	 to	 flip	 the	 alignment
direction.

Parallel:	Using	 this	mate,	you	can	make	an	axis,	 face,	or	edge	of	one	part
parallel	to	that	of	another	part.



Perpendicular:	Using	this	mate,	you	can	make	an	axis,	face	or	edge	of	one
part	perpendicular	to	that	of	another	part.

	
Concentric:	Using	this	mate,	you	can	align	the	centerlines	of	the	cylindrical

faces.



Click	 Flip	Mate	 Alignment	 to	 flip	 the	 alignment	 direction.	 Check	 the	Lock
Rotation	option	to	lock	the	rotation	between	components.

Lock:	Makes	parts	to	form	a	rigid	set.	As	you	move	a	single	part	in	a	rigid	set,
all	the	other	parts	will	also	be	moved.



Distance:	Applies	the	distance	mate	between	two	components.

Angle:	Applies	the	angle	mate	between	two	components.

	



Click	Flip	Dimension	to	reverse	the	angle	direction.

Tangent:	This	mate	makes	two	faces	tangent	to	each	other.

	

1.	 On	the	CommandManager,	click	Assembly	>	Mate .
2.	 On	the	Mate	PropertyManager,	click	Concentric .



3.	 Click	on	the	cylindrical	face	of	the	Shaft.

4.	 Click	on	the	inner	cylindrical	face	of	the	Flange

In	 SOLIDWORKS	 2016,	 the	 first	 selection	 is	 made	 transparent	 while
applying	mates.	You	 can	 turn	OFF	 the	 transparency	 by	 unchecking	 the	Make
first	 selection	 transparent	 option	 in	 the	 Options	 section	 of	 the	 Mate
PropertyManager.

5.	 Click	Add/Finish	Mate.

	This	aligns	the	Shaft	and	the	Flange	axially.

6.	 On	the	Mate	PropertyManager,	click	Coincident .
7.	 Click	on	the	front	face	of	the	shaft.



	
8.	 Rotate	the	model.
9.	 Click	on	the	slot	face	of	the	flange,	as	shown	in	figure.

10.	 On	 the	Mate	 PropertyManager,	 under	 the	Standard	Mates	 section,	 click
the	Aligned	button.

11.	 Click	OK	on	the	SOLIDWORKS	message.



12.	 Click	Add/Finish	Mate.

This	aligns	front	face	of	the	Shaft	and	the	slot	face	of	the	Flange.

	

13.	 On	the	Mate	PropertyManager,	click	Coincident .
14.	 In	the	FeatureManager	tree,	expand	Flange	and	select	Top	Plane.
15.	 Expand	Shaft	and	select	Right	Plane.



	

16.	 Click	Add/Finish	Mate.
17.	 Click	OK	on	the	PropertyManager.

This	assembles	the	two	components	and	fully	constrains	the	Shaft.

Adding	the	Third	Component
In	order	to	assemble	the	third	component,	you	need	to	hide	the	Flange.



1.	 In	the	FeatureManager	Design	Tree,	click	the	right	mouse	button	on	the
Flange	and	select	Hide	Components	to	hide	the	Flange.	Now,	it	is	easy	to
assemble	the	third	component.

SOLIDWORKS	 2016	 allows	 to	 hide	 a	 body	 placing	 the	 cursor	 on	 it	 and
pressing	 the	 Tab	 key.	 You	 can	 unhide	 the	 body	 by	 placing	 the	 cursor	 at	 its
position	and	pressing	Shift+Tab.

2.	 To	insert	the	third	component,	click	Assembly	>	Insert	Component .
3.	 On	the	PropertyManager,	click	the	Browse	button.
4.	 Browse	to	the	folder:	C:\Users\Username\Documents\Oldham	Coupling,

and	then	double-click	on	the	Key.
5.	 Click	inside	the	graphics	window	to	position	the	key.

6.	 Activate	the	Mate	 tool.
7.	 On	the	Mate	PropertyManager,	click	Coincident .
8.	 Right-click	on	the	side	face	of	the	key	and	select	Select	Other.



9.	 From	the	Select	Other	box,	select	the	bottom	face	of	the	Key.

10.	 Select	the	bottom	face	of	the	slot.

11.	 Click	Add/Finish	Mate .
12.	 This	aligns	the	bottom	face	of	the	key	with	the	bottom	face	of	the	slot.

13.	 Select	the	front	face	of	the	Key	and	back	face	of	the	Shaft.



14.	 Click	Flip	Alignment.

15.	 																																																						Click	Add/Finish	Mate .
16.	 This	applies	the	mate	between	the	selected	faces.

17.	 Click	on	the	top	face	of	the	key.



18.	 Rotate	the	shaft	and	select	the	side	face	of	the	slot.

19.	 Click	Add/Finish	Mate.

20.	 Click	OK	 on	the	PropertyManager.
21.	 																																																															Now,	you	have	to	turn-on	the	display	of	the	Flange.
22.	 Click	 the	 right	mouse	 button	 on	 the	Flange	 in	 the	FeatureManager	 tree,

and	then	select	Show	Components	to	display	the	Flange.



Checking	the	Interference
1.	 On	the	CommandManager,	click	Evaluate	>	Interference	Detection .
2.	 On	the	PropertyManager,	click	Calculate.

The	Results	section	shows	No	Interferences.														

3.	 Click	OK .

Saving	the	Assembly
1.	 Click	Save	 on	the	Quick	Access	Toolbar.
2.	 Enter	Flange_subassembly	in	the	File	name	field.
3.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.
4.	 Click	Save	to	save	the	file.
5.	 Click	File	>	Close.

Starting	the	Main	assembly
1.	 Click	the	New	 button	on	the	Quick	Access	Toolbar.
2.	 On	the	New	SOLIDWORKS	Document	dialog,	click	Assembly,	and	then

click	OK.

	
Adding	Disc	to	the	Assembly
1.	 On	the	Begin	Assembly	PropertyManager,	click	Browse.
2.	 Browse	 to	 the	 location	 C:\Users\Username\Documents\Oldham



Coupling	and	double-click	on	Disc.ipt.
3.	 Click	inside	the	graphics	window	to	place	the	component	at	the	origin.

															
Placing	the	Subassembly
1.	 To	 insert	 the	 subassembly,	 click	Assembly	 >	 Insert	 Components	 on

the	CommandManager.
2.	 Click	Browse	on	the	PropertyManager.
3.	 Browse	 to	 the	 location	 C:\Users\Username\Documents\Oldham

Coupling	and	double-click	on	Flange_subassembly.asm.
4.	 Click	in	the	window	to	place	the	flange	sub	assembly.

Adding	Constraints
1.	 Activate	the	Mate	 tool.
2.	 Click	on	the	front	face	of	the	disc	and	back	face	of	the	flange.



3.	 Click	Add/Finish	Mate.
4.	 Click	on	top	flat	face	of	the	disc.

	

5.	 Rotate	 the	 model	 geometry	 and	 click	 on	 the	 slot	 face	 of	 the	 flange,	 as
shown	in	figure.

	

6.	 Click	Add/Finish	Mate.



7.	 Click	on	the	cylindrical	faces	of	the	disc	and	flange.

8.	 Click	Add/Finish	Mate.
9.	 Click	OK.

Placing	the	second	instance	of	the	Subassembly
1.	 In	the	FeatureManager	Design	Tree,	click	on	the	Flange	assembly.
2.	 Press	Ctrl+C	on	your	keyboard	to	copy	the	assembly.
3.	 Press	Ctrl+V	to	paste	the	assembly.	Expand	the	copied	flange	assembly	in

the	 FeatureManager	 Design	 Tree	 and	 notice	 that	 it	 is	 copied	 along	 with
mates.

4.	 Mate	 the	 subassembly	 copy	 with	 the	 disc	 using	 the	 Coincident	 and
Concentric	 relations.



	
Saving	the	Assembly
1.	 Click	Save	on	the	Quick	Access	Toolbar.
2.	 Specify	Oldham_coupling	as	File	name.
3.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.
4.	 Click	Save	to	save	the	file.

	
TUTORIAL	2

In	 this	 tutorial,	 you	 create	 the	 exploded	 view	 of	 the	 assembly:	

Creating	the	Exploded	View
1.	 To	create	the	exploded	view,	click	Assembly	>	Exploded	View	 on	the

CommandManager.
2.	 On	 the	 Explode	 PropertyManager,	 under	 the	Explode	 Step	 type	 section,

click	Regular	Step .
3.	 On	the	Explode	PropertyManager,	under	the	Options	section,	check	Select

the	subassembly	parts.



4.	 Click	on	the	shaft,	and	then	click	on	the	Z-axis.

SOLIDWORKS	2016	 has	 an	 improved	 triad,	which	 helps	 you	 to	 rotate	 or
translate	parts	easily.
	

5.	 On	 the	 PropertyManager,	 under	 the	 Settings	 section,	 set	 the	 Explode
Distance	value	to	180.

6.	 Click	Apply,	and	then	click	Done.



	

7.	 Click	on	the	flange	and	set	the	Explosion	Distance	to	100.
8.	 Click	Apply,	and	then	click	Done.

9.	 Click	on	the	other	shaft	and	set	the	Explosion	Distance	to	-180.

10.	 Likewise,	explode	the	other	flange	to	-100	mm	distance.



11.	 Click	OK	on	the	PropertyManager.

Creating	Explode	lines
1.	 To	create	explode	lines;	click	Assembly	>	Explode	Line	Sketch .

2.	 Click	on	the	circular	edge	of	the	flange.

	

3.	 On	 the	 PropertyManager,	 under	 the	Options	 section,	 check	 the	Reverse
option.



	

4.	 Click	on	the	circular	edge	of	the	shaft.

	

5.	 Click	OK.

6.	 Click	on	the	vertices	of	the	flange	and	key,	as	shown	in	figure.
7.	 Click	OK.



8.	 Click	on	the	vertices	of	the	flange	and	disc,	as	shown	in	figure.

	

9.	 Click	OK.
10.	 Click	the	Jog	Line	button	located	next	to	the	PropertyManager.

	



11.	 Click	on	the	explode	line,	as	shown	in	figure.

	

12.	 Drag	the	pointer	to	draw	a	rectangle.

	

13.	 Press	the	Tab	key	to	change	the	orientation	of	the	sketch	line.

14.	 Click	to	draw	the	jogged	line.



	

15.	 Click	the	Route	Line	icon	located	next	to	the	PropertyManager.

	

16.	 Draw	the	other	explode	lines.	Click	OK	on	the	PropertyManager.



	

17.	 Click	Exit	Sketch.

The	ConfigurationManager	lists	all	the	explode	steps	and	exploded	lines.

To	 edit	 an	 explode	 step,	 click	 the	 right	 mouse	 button	 on	 it	 and	 select	 Edit
Feature.



To	collapse	the	explosion,	click	the	right	mouse	button	on	the	exploded	view	and
select	Collapse.

To	animate	the	explosion,	click	the	right	mouse	button	on	the	exploded	view	and
select	Animate	Explode.



	

18.	 Save	and	close	the	assembly	file.



Chapter	4:	Creating	Drawings

In	this	chapter,	you	create	drawings	of	the	parts	and	assembly	from	the	previous
chapters.

In	this	chapter,	you	will:

Create	model	views
Create	section	views
Create	detail	views
Add	dimensions	and	annotations
Create	Custom	templates
Insert	exploded	view	of	the	assembly
Insert	a	bill	of	materials	of	the	assembly
Apply	balloons	to	the	assembly	drawing



TUTORIAL	1
In	this	tutorial,	you	will	create	the	drawing	of	the	Flange.sldprt	file	created	in	the
second	chapter.



Opening	a	New	Drawing	File
1.	 To	 open	 a	 new	 drawing,	 click	 the	New	 button	 on	 the	Quick	 Access

Toolbar.
2.	 On	the	New	SOLIDWORKS	Document	dialog,	select	Drawing	and	click

OK.

3.	 Select	A3	(ANSI)	Landscape	 from	the	list	box	in	the	Sheet	Format/Size
dialog.

4.	 Click	OK.
5.	 Click	Cancel	on	the	Model	View	PropertyManager.

6.	 On	 the	 FeatureManager	 Design	 Tree,	 click	 the	 right	 mouse	 button	 on
Sheet1	and	select	Properties.



7.	 On	the	Sheet	Properties	dialog,	set	the	Type	of	projection	to	Third	angle.
8.	 Click	OK.

															
Generating	the	Base	View
1.	 On	the	CommandManager,	click	View	Layout	>	Model	View .
2.	 To	 generate	 the	 base	 view,	 click	 the	Browse	 button	 on	 the	Model	View

PropertyManager.

	
3.	 Browse	to	the	location

C:	 UserDocument/Oldham_Coupling	 and	 double-click	 on
Flange.sldprt.

4.	 On	the	Model	View	PropertyManager,	under	the	Orientation	section,	click
Front.



5.	 Click	 on	 the	 sheet	 to	 position	 the	 view.	 The	 Projected	 View	 tool	 gets
active.

6.	 Click	OK	 on	the	PropertyManager.
7.	 On	 the	View	Heads-up	 toolbar,	 click	 the	Hide	 flyout	and	make	sure	 that

the	View	Origin	icon	is	deactivated.

	
Creating	the	Section	View



1.	 To	create	 the	 section	view,	click	View	Layout	>	Section	View	 on	 the
CommandManager.

2.	 Snap	to	 the	center	point	of	 the	base	view	and	click	to	position	the	section
line.

3.	 Click	OK.

4.	 Move	the	pointer	toward	right	and	click	to	place	the	section	view.
5.	 Click	the	green	check	on	the	PropertyManager.



Creating	the	Detailed	View
Now,	 you	 need	 to	 create	 the	 detailed	 view	 of	 the	 keyway	 that	 appears	 on	 the
front	view.

1.	 To	 create	 the	 detailed	view,	 click	View	Layout	>	Detail	View	 on	 the
CommandManager.

2.	 Specify	the	center	point	and	boundary	point	of	the	detail	view,	as	shown	in
figure.

3.	 On	 the	PropertyManager,	 under	 the	Detail	Circle	 section,	 set	 the	 options
shown	below.



4.	 Set	the	Display	Style	and	Scale	options,	as	shown	below.

5.	 Place	 the	 detail	 view	 below	 the	 base	 view.	 Click	 OK	 on	 the
PropertyManager.

														 	

In	SOLIDWORKS	2016,	you	can	change	the	scale	of	the	drawing	views	by
using	 the	 drop-down	 available	 at	 the	 bottom	 right.	 Note	 that	 the	 scale	 of	 the
detail	view	remains	unchanged.



Creating	the	Centerline
1.	 On	the	CommandManager,	click	Annotation	>	Centerline .
2.	 Click	on	the	inner	horizontal	edges	of	the	section	view,	as	shown	in	figure.

3.	 Click	OK	 on	the	PropertyManager.

Specifying	Dimension	Settings



1.	 To	 specify	 the	 dimension	 settings,	 click	Options	 on	 the	Quick	 Access
Toolbar.

2.	 On	 the	 dialog,	 under	 the	 Document	 Properties	 tab,	 click	 Drafting
Standard.

3.	 Select	Overall	drafting	standard	>	ANSI.

4.	 Under	Drafting	Standard,	click	Dimensions.
5.	 Under	Primary	Precision,	select	Unit	Precision	>	None.

6.	 At	the	bottom	of	the	dialog,	check	the	Center	between	extension	lines.



7.	 Click	OK.
8.	 At	the	bottom	of	the	window,	set	the	Unit	System	to	MMGS.

Retrieving	Dimensions
Now,	 you	 will	 retrieve	 the	 dimensions	 that	 were	 applied	 to	 the	 model	 while
creating	it.

1.	 To	 retrieve	 dimensions,	 click	 Annotation	 >	 Model	 Items	 on	 the
CommandManager.

2.	 On	the	PropertyManager,	select	Source	>	Entire	model.
3.	 Uncheck	the	Import	Items	into	all	views	option.
4.	 Under	the	Dimensions	section,	select	Marked	for	drawing.



5.	 Click	 on	 the	 view	 boundary	 of	 the	 section	 view	 and	 click	OK 	 on	 the
PropertyManager.

6.	 Drag	and	arrange	the	dimensions.



Adding	additional	dimensions
1.	 To	 add	 dimensions,	 click	 Annotation	 >	 Smart	 Dimension	 	 on	 the

CommandManager.
2.	 On	 the	 section	 view,	 click	 on	 the	 fillet	 edge	 and	 position	 the	 radial

dimension.

3.	 Select	the	radial	dimension	and	click	on	the	arrow	to	change	its	direction.



4.	 On	 the	detail	 view,	 click	on	 the	vertical	 edge	of	 the	 slot	 and	position	 the
dimension.

5.	 Likewise,	add	dimension	to	the	horizontal	edge	of	the	slot.



6.	 On	the	CommandManager,	click	Annotation	>	Hole	Callout .
7.	 Click	on	the	innermost	circular	edge	of	the	front	view	and	position	the	hole

callout.
8.	 Click	Close	Dialog	on	the	PropertyManager

Saving	the	Drawing
1.	 Click	Save	on	the	Quick	Access	Toolbar.
2.	 Specify	Flange	as	Name.
3.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.
4.	 Click	Save	to	save	the	file.
5.	 Click	File	>	Close.



TUTORIAL	2
In	 this	 tutorial,	 you	 will	 create	 the	 drawing	 of	 Disc.sldprt	 file	 created	 in	 the
second	chapter.

Creating	a	Custom	Sheet	Format
1.	 On	Quick	Access	Toolbar,	click	the	New	button.
2.	 On	the	New	SOLIDWORKS	Document	dialog,	select	Drawing	and	click

OK.

6.	 Select	A3	(ANSI)	Landscape	 from	the	list	box	in	the	Sheet	Format/Size
dialog.

7.	 Click	OK.
8.	 Close	the	Model	View	PropertyManager.
9.	 On	 the	 FeatureManager	 Design	 Tree,	 click	 the	 right	 mouse	 button	 on

Sheet1	and	select	Properties.
10.	 On	the	Sheet	Properties	dialog,	set	the	Type	of	projection	to	Third	angle.

Click	OK.
11.	 On	the	CommandManager,	click	Sheet	Format	>	Edit	Sheet	Format .
12.	 Zoom	to	the	title	block,	and	then	select	the	lines	and	notes	shown	in	figure.

Press	Delete	on	your	keyboard.

3.	 On	the	CommandManager,	click	Sketch	>	Line	 and	draw	a	line	on	the
title	block.



4.	 On	the	CommandManager,	click	Annotation	>	Note .
5.	 On	 the	 PropertyManager,	 under	 the	Text	Format	 section,	 select	Link	 to

Property.

6.	 On	the	Link	to	Property	dialog,	select	Current	document.
7.	 Select	 SW-Author	 (Author)	 from	 the	 Property	 name	 drop-down,	 and

then	click	OK.



8.	 On	the	PropertyManager,	under	the	Leader	section,	select	No	Leader.

9.	 Click	inside	the	box,	as	shown	in	figure.

10.	 On	the	Formatting	toolbar,	set	the	font	size	to	8	and	type	Author.



11.	 Click	OK	 on	the	PropertyManager.

12.	 On	the	Menu	bar,	click	Insert	>	Picture.
13.	 Select	your	company	logo	and	click	Open.
14.	 Resize	and	position	the	image	on	the	title	block.

15.	 Click	OK	 on	the	PropertyManager.
16.	 Click	Exit	Sheet	Format.

17.	 On	the	Quick	Access	Toolbar,	click	Options .
18.	 On	 the	 dialog,	 under	 the	 Document	 Properties	 tab,	 click	 Drafting

Standard.
19.	 Select	Overall	drafting	standard	>ANSI.
20.	 Click	Units	and	set	the	Unit	System	to	MMGS.
21.	 Click	OK.
22.	 Click	File	>	Save.
23.	 On	the	Save	As	dialog,	select	Save	as	type	>	Drawing	Templates.



24.	 Browse	to	C:\Users\Username\Documents\Oldham	Coupling	folder.
25.	 Type-in	Sample	in	the	File	name	box	and	click	Save.
26.	 On	the	Menu	bar,	click	File	>	Close.

Starting	a	New	drawing
1.	 On	the	Quick	Access	Toolbar,	click	the	Options	 button.
2.	 On	the	System	Options	dialog,	click	File	Locations.
3.	 Select	Show	folders	for	>	Document	Templates	and	click	the	Add	button.

4.	 Browse	 to	 C:\Users\Username\Documents\Oldham	 Coupling	 folder.
Click	OK.

5.	 Click	OK	on	the	System	Options	dialog,	and	then	click	Yes.
6.	 On	the	Quick	Access	Toolbar,	click	the	New	button.
7.	 On	 the	 New	 SOLIDWORKS	 Document	 dialog,	 click	 the	 Advanced

button.
8.	 Under	the	Oldham	Coupling	tab,	select	Sample	and	click	OK.



Generating	the	Drawing	Views
1.	 On	the	Model	View	PropertyManager,	click	the	Browse	button	and	browse

to	the	location:

C:	UserDocument/Oldham_Coupling
2.	 Double-click	on	Disc.sldprt.
3.	 On	the	PropertyManager,	under	the	Orientation	section,	check	the	Create

multiple	views	option.
4.	 Select	the	Front	and	Bottom	views.

5.	 Click	OK	on	the	PropertyManager.

6.	 On	the	CommandManager,	click	Annotation	>	Model	Items .
7.	 On	the	PropertyManager,	select	Source	>	Entire	model.
8.	 Click	on	the	two	views	and	click	OK .



9.	 Click	 the	 right	mouse	 button	 on	 the	 100-diameter	 dimension	 on	 the	 front
view	and	select	Display	Options	>	Display	as	Diameter.

10.	 Arrange	the	dimensions	by	dragging	them.



11.	 Save	and	close	the	drawing	file.



TUTORIAL	3
In	 this	 tutorial,	 you	 will	 create	 the	 drawing	 of	 Oldham	 coupling	 assembly
created	in	the	previous	chapter.

Creating	the	Isometric	View
1.	 Start	a	new	drawing	file	using	the	Sample	template.
2.	 On	the	Model	View	PropertyManager,	click	the	Browse	button.
3.	 Browse	 to	 the	 location	 C:	 UserDocument/Oldham_Coupling	 folder	 and

double-click	on	Oldham_Coupling.sldasm.
4.	 On	the	Model	View	PropertyManager,	under	the	Reference	Configuration

section,	uncheck	the	Show	in	exploded	or	model	break	state	option.
5.	 Under	the	Orientation	section,	select	Isometric.

6.	 Under	the	Scale	section,	select	Use	custom	scale	and	set	the	scale	factor	to
1:2.

7.	 Click	on	the	sheet	to	position	the	view.



8.	 Click	the	green	check	on	the	PropertyManager.

Generating	the	Exploded	View
1.	 On	the	CommandManager,	click	View	Layout	>	Model	View .
2.	 On	 the	 PropertyManager,	 under	 the	 Part/Assembly	 to	 Insert	 section,

double-click	on	Oldham	Coupling.

3.	 Under	the	Reference	Configuration	section,	enable	Shown	in	exploded	or
model	break	state.

4.	 Under	the	Orientation	section,	select	Isometric .
5.	 Under	the	Scale	section,	select	Use	custom	scale	and	set	the	scale	factor	to

1:2.
6.	 Click	on	the	sheet	to	position	the	exploded	view.



													
Creating	the	Bill	of	Materials
1.	 Click	the	right	mouse	button	on	the	sheet	and	select	Edit	Sheet	Format.
2.	 Click	on	the	top	right	corner	of	the	sheet	border.

3.	 Click	the	right	mouse	button	and	select	Set	Anchor	as	>	Bill	of	Materials.

4.	 Click	Close	Dialog	 on	the	Point	PropertyManager.
5.	 Click	the	right	mouse	button	on	the	sheet	and	select	Edit	Sheet.



6.	 To	create	a	parts	list,	click	Annotation	>	Tables	>	Bill	of	Materials	on	the
CommandManager.

7.	 Click	on	the	exploded	view.
8.	 On	 the	 PropertyManager,	 under	 the	 Table	 Position	 section,	 check	 the

Attach	to	anchor	point	option.
9.	 Set	the	BOM	Type	to	Parts	only.

10.	 Click	OK.	You	will	notice	that	the	BOM	appears	outside	the	sheet.

11.	 Click	on	the	anchor	point	of	the	BOM.



12.	 On	 the	 PropertyManager,	 under	 the	 Table	 Position	 section,	 select	 Top
Right.

13.	 Click	the	green	check	 on	the	PropertyManager.

Creating	Balloons																																																							
1.	 To	 create	 balloons,	 click	 Annotation	 >	 Auto	 Balloon 	 on	 the

CommandManager.

2.	 On	 the	 PropertyManager,	 under	 Balloon	 Layout	 section,	 select	 Layout
Balloons	to	Right .

3.	 Click	on	the	exploded	view	and	click	OK .



	

4.	 Save	and	close	the	drawing	file.

	
	
	
	



Chapter	5:	Sketching

In	this	chapter,	you	will	learn	the	sketching	tools.	You	will	learn	to	create:

Rectangles
Polygons
Resolve	Sketch
Relations
Splines
Ellipses
Move,	rotate,	scale,	copy,	and	stretch	entities
Circles
Arcs
Circular	pattern
Trim	Entities
Fillets	and	Chamfers

Creating	Rectangles
A	rectangle	is	a	four	sided	object.	You	can	create	a	rectangle	by	just	specifying
its	two	diagonal	corners.	However,	there	are	various	tools	to	create	a	rectangle.
You	 can	 access	 these	 tools	 from	 the	 Rectangle	 drop-down	 available	 on	 the
Sketch	CommandManager.	These	tools	are	explained	next.

1.	 On	 the	CommandManager,	 click	Sketch	>	Sketch	 and	 select	 the
Front	plane.

2.	 On	 the	CommandManager,	 click	Sketch	>	Rectangle	Drop-down	>
Corner	Rectangle .

3.	 Select	the	origin	point	to	define	the	first	corner.
4.	 Move	the	pointer	diagonally	and	click	to	define	the	second	corner.



5.	 On	the	PropertyManager,	click	the	Center	Rectangle	 	icon	under
the	Rectangle	Type	section.

6.	 Click	in	the	graphics	window	to	define	the	center	point.
7.	 Move	the	pointer	and	click	to	define	the	corner.

8.	 On	the	PropertyManager,	select	From	Midpoints	under	the	Rectangle
Type	section.

9.	 Select	 the	 center	 point	 and	 corner	 point	 of	 the	 rectangle.	 Two
construction	lines	are	created	from	the	midpoints	of	the	rectangles.

10.	 On	 the	 PropertyManager,	 click	 the	 3	 Point	 Corner	Rectangle	
icon	under	 the	Rectangle	 type	 section.	This	 option	 creates	 a	 slanted
rectangle.	You	 can	 also	 check	 the	Add	 construction	 lines	 option	 to
add	construction	lines	between	the	corners	or	midpoints.

11.	 Select	 two	 points	 to	 define	 the	 width	 and	 inclination	 angle	 of	 the
rectangle.

12.	 Select	the	third	point	to	define	its	height.



13.	 On	 the	 PropertyManager,	 click	 the	 3	 Point	 Center	 Rectangle	
icon	under	the	Rectangle	Type	section.

14.	 Click	to	define	the	center	point	of	the	rectangle.
15.	 Move	the	pointer	and	click	to	define	the	midpoint	of	one	side.

16.	 Move	the	pointer	and	click	to	define	the	corner	point.

17.	 On	the	PropertyManager,	click	the	Parallelogram	 icon	under	the
Rectangle	Type	section.	This	option	creates	a	parallelogram	by	using
three	points	that	you	specify.

18.	 Select	two	points	to	define	the	width	of	the	parallelogram.



19.	 Drag	the	pointer	and	click	to	define	the	height	of	parallelogram.

20.	 Click	Close	Dialog	 on	the	PropertyManager.

Lasso	Selection
The	Lasso	Selection	 tool	 helps	 you	 to	 select	multiple	 elements	 by	 dragging
the	pointer	over	them.
	

1.	 Click	the	right	mouse	button	and	select	Lasso	Selection.

2.	 Click	the	left	mouse	button	and	drag	the	pointer	covering	the	three	elements
of	the	rectangle,	as	shown.

The	three	elements	will	be	selected.



3.	 Press	Delete	to	erase	the	elements	of	the	rectangle.
4.	 Press	Ctrl+A	to	select	all	the	sketch	elements.
5.	 Press	Delete	to	erase	the	elements.

Creating	Polygons
A	 Polygon	 is	 a	 shape	 having	 many	 sides	 ranging	 from	 3	 to	 1024.	 In
SOLIDWORKS,	you	can	create	regular	polygons	having	sides	with	equal	length.
Follow	the	steps	given	next	to	create	a	polygon.

1.	 Activate	the	Sketch	mode.
2.	 On	the	CommandManager,	click	Sketch	>	Polygon .
3.	 On	 the	 PropertyManager,	 type	 8	 in	 the	Number	 of	 Sides	 box	 under	 the

Parameters	section.
4.	 Select	 Inscribed	 circle.	 This	 option	 creates	 a	 polygon	 with	 its	 sides

touching	 a	 dotted	 circle.	 You	 can	 also	 select	 the	Circumscribed	 circle
option	to	create	a	polygon	with	its	vertices	touching	a	dotted	circle.

5.	 Click	to	define	the	center	of	the	polygon.
6.	 Move	the	pointer	and	click	to	define	the	size	and	angle	of	the	polygon.

7.	 Press	Esc	to	deactivate	the	tool.



Resolve	Sketch
When	creating	sketches	for	a	part,	SOLIDWORKS	will	not	allow	you	to	over-
constrain	 the	 geometry.	 The	 term	 ‘over-constrain’	 means	 adding	 more
dimensions	 than	 required.	 	 The	 following	 figure	 shows	 a	 fully	 constrained
sketch.	 If	 you	 add	 another	 dimension	 to	 this	 sketch	 (e.g.	 diagonal	 dimension),
the	Make	Dimension	Driven	dialog	appears.

Now,	 you	 have	 to	 convert	 the	 new	 dimension	 into	 driven.	 Select	Make	 this
dimension	driven	and	click	OK.



Now,	 if	 you	 change	 the	value	of	 the	width,	 the	 reference	dimension	 along	 the
diagonal	updates,	automatically.

Relations
Relations	are	used	to	control	the	shape	of	a	sketch	by	establishing	relationships
between	the	sketch	elements.	You	can	add	relations	using	the	Add	Relation	tool
or	pop-up	toolbar	or	by	selecting	sketch	elements.

Merge
This	relation	connects	a	point	to	another	point.

1.	 On	 the	 Sketch	 tab	 of	 the	 CommandManager,	 click	 Delete/Display
Relations	>	Add	Relation .

2.	 Select	two	points.
3.	 Click	 Merge 	 on	 the	 PropertyManager.	 The	 selected	 points	 will	 be

merged	together.

Horizontal
To	apply	the	Horizontal	relation,	click	on	a	line	and	click	the	Horizontal	icon
on	the	context	toolbar.



You	 can	 also	 align	 two	 points	 or	 vertices	 horizontally.	 Press	 the	Ctrl	 key	 and
select	the	two	points.	Click	the	Horizontal	icon	on	the	PropertyManager.

Vertical
Use	the	Vertical	relation	to	make	a	line	vertical.	You	can	also	align	two	vertices
vertically	by	using	this	relation.

Tangent
This	relation	makes	an	arc,	circle,	or	line	tangent	to	another	arc	or	circle.	Select	a
circle,	arc,	or	line.	Press	the	Ctrl	key	and	select	another	circle,	or	arc.	Click	the
Tangent	icon	on	the	PropertyManager.	The	two	elements	will	be	tangent	to	each
other.

Parallel
Use	the	Parallel	relation	to	make	two	lines	parallel	to	each	other.

Perpendicular



Use	the	Perpendicular	relation	to	make	two	entities	perpendicular	to	each	other.

Midpoint
Use	the	Midpoint	relation	to	make	a	point	coincide	with	the	midpoint	of	a	line
or	arc.

1.	 Press	the	Ctrl	key	and	select	and	line/arc	and	a	point.
2.	 Click	the	Midpoint	icon	on	the	PropertyManager.

Automatic	Relations
SOLIDWORKS	automatically	adds	relations	when	you	create	sketch	elements.

1.	 Start	 a	 new	 sketch	 and	 activate	 the	 Line	 tool	 from	 the	 Sketch
CommandManager.

2.	 Click	to	specify	the	start	point	of	the	line.
3.	 Move	 the	 pointer	 in	 the	 horizontal	 direction	 and	 notice	 the	 Horizontal

relation	flag.
4.	 Click	to	create	a	line	with	the	Horizontal	relation.

5.	 Likewise,	create	a	line	with	the	Vertical	relation.



6.	 Create	an	inclined	line	as	shown.

7.	 Move	the	pointer	along	the	 inclined	 line	and	notice	 the	Collinear	 relation
flag.

8.	 Move	the	pointer	in	the	direction	perpendicular	to	inclined	line	and	notice
the	Perpendicular	relation	flag.

9.	 Click	to	create	the	line	with	the	Perpendicular	relation.

10.	 Press	Esc	to	deactivate	the	Line	tool.
11.	 Select	the	perpendicular	line.



12.	 Right	click	and	select	Sketch	Entities	>	Line.
13.	 Click	 in	 the	graphics	window	to	specify	 the	start	point	of	 the	 line.	Notice

the	yellow	inferred	lines	with	reference	to	the	selected	line.
14.	 Move	along	the	yellow	inferred	line	notice	the	Parallel	relation	flag.

15.	 Click	to	create	a	line	parallel	to	the	selected	line.
16.	 Press	Esc	to	deactivate	the	Line	tool.
17.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Circle ,	 and	 then	 create

circle.
18.	 Activate	the	Line	tool	and	click	on	the	circle.
19.	 Move	 the	 pointer	 around	 the	 circle	 and	 notice	 that	 the	 line	maintains	 the

Tangent	relation	with	the	circle.



20.	 Click	 to	 create	 a	 line	which	 is	 tangent	 and	 coincident	 to	 the	 circle.	Right
click	and	select	End	chain.

21.	 Select	a	point	on	the	circle	and	move	the	pointer.
22.	 Move	the	pointer	back	to	the	start	point	of	the	line.

Notice	the	Coincident	relation	flag	and	the	yellow	inferred	lines.
You	 can	 create	 a	 line	 which	 is	 tangent	 or	 normal	 to	 the	 circle
using	the	inferred	lines.

Deleting	Relations
You	can	delete	relations	by	using	the	following	methods



Select	the	relation	and	press	Delete.
Select	 the	 sketch	 entity	 to	 view	 all	 its	 relations	 in	 the	 PropertyManager.
Select	 the	 relations	 from	 the	 Existing	 Relations	 section	 of	 the
PropertyManager	and	press	Delete.
On	 the	 CommandManager,	 click	Sketch	 >	Display/Delete	Relations .
On	the	PropertyManager,	select	the	relations	from	the	Relations	section	and
click	 Delete.	 You	 can	 also	 use	 the	 Delete	 All	 button	 to	 delete	 all	 the
relations.

Hiding	Relations
To	 hide	 sketch	 relations	 by	 clicking	 the	Hide/Show	 Items	 drop-down	 on
the	View	Heads-Up	Toolbar,	and	then	deactivating	the	View	Sketch	Relations	
icon.

Sketch	Numeric	Input
The	Sketch	Numeric	 Input	 tool	 automatically	 adds	 dimensions	 to	 the	 sketch
elements	when	you	create	them.

1.	 Click	the	Right	Mouse	button	and	select	Sketch	Numeric	Input	 from	the
shortcut	menu.



2.	 Activate	 a	 sketching	 tool	 and	 check	 the	Add	 Dimensions	 option	 on	 the
PropertyManager.	 In	 case	 of	 a	 circle,	 you	 can	 select	 the	 Diameter
dimensions	option	to	add	the	diameter	dimension	to	the	circle.

3.	 Start	creating	the	sketch	elements.	Notice	that	you	can	enter	the	dimension
values	 of	 the	 sketch	 elements.	 Use	 the	 Tab	 key	 to	 walk	 through	 the
dimension	values.

You	 can	 change	 the	 dimension	 units	 from	 flyout	 located	 at	 the
bottom	 right	 corner	 of	 the	 window.	 The	 dimension	 units	 are
reflected	in	the	sketch.

Replace	Entity
The	Replace	Entity	tool	replaces	a	sketch	entity	with	another	one.	You	can	use
this	 tool	 instead	of	deleting	a	 sketch	entity	and	creating	another	one.	This	 tool
transfers	 all	 the	 associated	 features	 of	 the	 replaced	 entity	 to	 the	 replacement
entity.	This	will	avoid	any	parent-child	errors	when	you	modify	the	sketch.	The
following	example	shows	the	significance	of	this	tool.

1.	 Start	a	new	sketch	on	the	Front	plane	and	create	the	sketch,	as	shown.



2.	 On	the	Sketch	CommandManager,	click	the	Smart	Dimension	 tool.
3.	 Select	the	inclined	line	and	the	vertical	line	connected	to	it.

4.	 Place	the	dimension,	type	115	in	the	Modify	box,	and	then	click	OK.
5.	 Select	the	inclined	line	and	move	the	pointer.	Notice	that	the	orientation	of

the	dimension	changes	as	per	the	movement	of	the	pointer.
6.	 Move	the	pointer	vertically	upward	and	right	click	to	lock	the	orientation	of

the	dimension.	Now,	the	orientation	of	the	dimension	does	not	change	with
the	cursor	movement.

7.	 Place	the	dimension	the	specify	its	value	as	35.
8.	 Likewise,	add	other	dimensions	to	the	sketch.

9.	 Exit	the	sketch,	and	then	extrude	it	up	to	50	mm	distance.



10.	 Activate	the	Extrude	Boss/Base	tool	and	click	on	the	horizontal	face	of	the
model.

11.	 Create	the	sketch	as	shown.	Exit	the	sketch.

12.	 On	the	PropertyManager,	select	Up	To	Surface	from	the	Direction	1	drop-
down.



13.	 Select	the	inclined	face	of	the	model,	and	then	click	OK.

14.	 In	the	FeatureManager	Design	Tree,	expand	the	Boss-Extrude1,	click	on	the
Sketch1,	and	then	select	the	Edit	Sketch.

15.	 Select	the	inclined	line	and	press	Delete.

16.	 Click	Yes.
17.	 Create	a	3-point	arc	closing	the	sketch	loop,	as	shown.



18.	 Click	Exit	Sketch.	The	What’s	Wrong	 dialog	pops	up	on	 the	 screen.	 Its
shows	that	the	end	face	cannot	terminate	the	extruded	feature.

19.	 Press	Ctrl+Z	thrice	to	undo	the	changes.
20.	 Again,	click	on	the	Sketch1	in	the	FeatureManager	Design	Tree	and	select

Edit	Sketch.
21.	 Create	an	arc,	as	shown.

22.	 Right	click	and	select	Replace	Entity	from	the	shortcut	menu.

23.	 Select	the	inclined	line	as	the	entity	to	be	replaced.
24.	 Select	the	arc	as	the	replacing	entity.
25.	 Check	 the	Make	 construction	 option	 on	 the	 PropertyManager,	 and	 the

click	OK.
26.	 Exit	the	sketch	and	notice	that	end	face	of	the	extruded	feature	is	replaced.



Make	Path
The	Make	 Path	 tool	 creates	 path	 combining	 all	 the	 sketch	 entities.	When	 you
apply	 a	 relation	 between	 anyone	of	 the	 entity	 of	 the	 path	 and	other	 individual
entity,	the	relation	will	be	persistent	through	all	the	entities	of	the	path.

1.	 Create	a	closed	sketch	and	a	circle,	as	shown.

2.	 On	the	Menu	bar,	click	Tools	>	Sketch	Tools	>	Make	Path .
3.	 Select	 all	 the	 entities	 of	 the	 closed	 loop,	 and	 the	 click	 OK	 on	 the

PropertyManager.
4.	 Apply	the	Tangent	relation	between	the	circle	and	anyone	of	the	entity	of

the	closed	loop.
5.	 Click	and	drag	the	circle	notice	that	it	maintains	the	Tangent	relation	with

all	the	entities	of	the	path.



Path	Length	Dimension
The	 Path	 Length	 Dimension	 tool	 defines	 a	 fixed	 length	 for	 all	 the	 sketch
entities	combined	together.

1.	 Create	he	sketch	as	shown.

2.	 On	the	Sketch	CommandManager,	click	Smart	Dimension	>	Path	Length
Dimension .

3.	 Drag	a	selection	box	across	all	the	sketch	entities	to	select	them.
4.	 Click	OK	on	the	PropertyManager.
5.	 Double	click	on	the	Path	Length	dimension,	type	200,	and	press	Enter.
6.	 Click	and	drag	the	bottom	horizontal	line	of	the	sketch.	Notice	that	the	path

length	is	fixed	and	the	sketch	shape	changes.

Convert	Entities
The	Convert	Entities	 tool	 helps	you	 to	 use	 the	 edges	of	 the	part	 geometry	 to



create	sketch	elements.

1.	 Start	a	sketch	on	the	plane	offset	to	the	model	face,	as	shown.
2.	 On	the	Sketch	CommandManager,	click	the	Convert	Entities	 button.
3.	 Select	the	face	of	the	model,	as	shown.

4.	 On	 the	PropertyManager,	 click	 the	Select	all	 inner	 loops	 button	 to	 select
the	inner	loops	of	the	face.

5.	 Click	on	Face<1>	in	the	Entities	to	convert	selection	box,	and	then	select
Delete.

6.	 Click	OK	 on	the	PropertyManager.	All	the	internal	loops	of	the	selected
face	are	projected	onto	the	sketch	plane.



7.	 Select	 the	 previously	 selected	 face,	 and	 then	 click	 the	Convert	 Entities
button	 on	 the	 Sketch	 CommandManager.	 The	 outer	 loop	 of	 the	 face	 is
converted	into	sketch	elements.

Midpoint	line,	Perimeter	Circle,	and	SketchXpert
In	this	tutorial,	you	will	create	a	sketch	using	the	Midpoint	line	and	Perimeter
Circle	tools.

1.	 Activate	the	Sketch	mode.
2.	 On	 the	CommandManager,	 click	Sketch	>	Line	drop-down	>	Midpoint

Line .
3.	 Click	on	the	origin	point	to	define	the	midpoint	of	the	line.
4.	 Move	the	pointer	horizontally	and	click.



5.	 Move	 the	 pointer	 upward	 and	 click	 when	 a	 dotted	 line	 appear	 from	 the
midpoint	of	the	horizontal	line.

6.	 Create	another	line	closing	the	sketch.
7.	 Press	Esc	to	deactivate	the	Line	tool.

8.	 Apply	 the	Equal	 relation	 between	 the	 three	 the	 line	 segments	 and	 add	 a
dimension	to	one	segment.

9.	 On	the	CommandManager,	click	Sketch	>	Circle	drop-down	>	Perimeter



Circle .
10.	 Click	on	the	endpoints	of	three	lines.	The	circle	is	created	passing	through

the	endpoints.	Make	sure	that	you	click	the	endpoints	when	the	Coincident	
symbol	appears.

Notice	that	the	sketch	is	over-constrained.	You	can	solve	an	over-
constrained	sketch	using	the	SketchXpert.

11.	 On	the	Menu	Bar,	click	Tools	>	Sketch	Tools	>	SketchXpert.
12.	 On	the	SketchXpert	PropertyManager,	click	the	Diagnose	button.
13.	 Under	 the	Results	 section,	 click	 the	Next	 	 button	 to	 go	 through	 the

different	results.
14.	 Click	Accept	when	 the	 1	 of	 3	 result	 is	 displayed.	 It	 deletes	 the	Tangent

relation	from	the	sketch.
15.	 Click	OK	on	the	PropertyManager.
16.	 Click	 the	 right	mouse	button	and	 select	Recent	Commands	>	Perimeter

Circle.
17.	 Select	the	three	lines	to	create	a	circle	tangent	to	them.

Ellipses
Ellipses	 are	 also	 non-uniform	 curves,	 but	 they	 have	 a	 regular	 shape.	They	 are
actually	splines	created	in	regular	closed	shapes.



1.	 Activate	the	Sketch	mode.
2.	 On	the	CommandManager,	click	Sketch	>	Ellipse	drop-down	>	Ellipse .
3.	 Pick	a	point	in	the	graphics	window	to	define	the	center	of	the	ellipse.
4.	 Move	the	pointer	and	click	to	define	the	radius	and	orientation	of	the	first

axis.

5.	 Move	the	pointer	and	click	to	define	the	radius	of	the	second	axis.

Click	and	drag	the	ellipse	the	notice	that	it	is	under-defined.
You	need	to	add	dimensions	and	relations	to	fully	define	the
ellipse.

6.	 Activate	the	Line	tool	and	select	the	top	quadrant	point	of	the	ellipse.
7.	 Move	the	pointer	downward	and	select	the	centerpoint.
8.	 Move	the	pointer	toward	right	and	select	the	quadrant	point.



9.	 Press	the	Ctrl	key	and	select	the	two	lines.
10.	 Select	Perpendicular	 from	the	PropertyManager.
11.	 Right	click	and	select	Construction	Geometry.

12.	 On	the	Sketch	CommandManager,	click	the	Smart	Dimension	 tool.
13.	 Select	the	major	axis	line	of	the	ellipse.
14.	 Select	 the	 origin	 point	 of	 the	 sketch.	 Notice	 the	 horizontal	 and	 vertical

vectors	of	the	sketch.
15.	 Select	the	horizontal	vector	of	the	sketch.	The	angled	dimension	is	attached

to	the	pointer.													

16.	 Move	the	pointer	and	place	the	angled	dimension.

17.	 Type	15	and	click	OK.
18.	 Add	the	major	and	minor	axes	dimensions	to	the	sketch.	This	fully-defines

the	sketch.



Partial	Ellipse
1.	 On	 the	CommandManager,	 click	Sketch	 >	Ellipse	 drop-down	>	 Partial

Ellipse .
2.	 Click	to	define	the	center	of	the	partial	ellipse.
3.	 Move	the	pointer	and	click	to	define	the	radius	and	orientation	of	the	first

axis.

4.	 Move	the	pointer	and	click	to	define	the	radius	of	the	second	axis	and	start
point.

5.	 Rotate	the	pointer	and	click	to	define	end	point.



6.	 Click	Close	Dialog	on	the	PropertyManager.

Conic
The	Conic	 tool	 is	 used	 to	 create	 conic	 curve.	 You	 can	 use	 a	 conic	 curve	 to
connect	two	open	sketch	entities.

1.	 Create	a	line	and	arc,	as	shown.

2.	 On	the	Sketch	CommandManager,	click	Ellipse	drop-down	>	Conic .
3.	 Select	the	endpoints	of	the	line	and	arc.
4.	 Move	the	pointer	and	notice	the	dotted	lines.	These	lines	are	tangent	to	the

line	and	arc.
5.	 Select	 the	 intersection	point	 of	 the	dotted	 tangent	 lines.	Move	 the	pointer

and	notice	the	rho	value	displayed.	The	rho	value	defines	the	type	of	conic
created.

6.	 Click	to	the	create	the	conic	curve.	Now,	you	have	to	specify	the	Rho	value
of	the	conic	curve.

7.	 Expand	 the	Parameters	section	of	 the	PropertyManager,	and	 then	 type	0.5



in	the	ρ	box.
8.	 Click	Close	Dialog	 on	the	PropertyManager.

Move	and	Rotate	Entities
The	Move	Entities	 tool	moves	a	selected	object(s)	from	one	location	to	a	new
location	without	 changing	 its	 orientation.	 To	move	 objects,	 you	must	 activate
this	 tool	 and	 select	 the	 objects	 from	 the	 graphics	 window.	 After	 selecting
objects,	you	must	define	the	‘base	point’	and	the	‘destination	point’.
	

1.	 Create	the	sketch,	as	shown	below.

2.	 Click	Sketch	>	Move	Entities	 on	the	CommandManager.
3.	 Select	the	square	located	at	the	right-side	by	dragging	a	selection	box,	and

then	right-click	to	accept	the	selection.
4.	 On	the	PropertyManager,	under	the	Parameter	section,	select	From/To.
5.	 Select	the	lower	corner	point	as	the	base	point.
6.	 Move	the	pointer	toward	right	and	pick	a	point	as	shown	below.	This	moves

the	square	to	the	new	location.

Rotate	Entities



The	Rotate	Entities	 tool	 rotates	 an	 object	 or	 a	 group	 of	 objects	 about	 a	 base
point.	

1.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Move	 Entities	 >	 Rotate
Entities .

2.	 Drag	 a	 selection	 box	 covering	 the	 sketch	 elements,	 and	 click	 the	 right
mouse	button.

3.	 Click	to	define	the	base	point	of	the	rotation.

4.	 Click	again	and	rotate	the	sketch	entities.	You	can	also	type-in	the	rotation
angle	on	the	PropertyManager.

5.	 Click	OK	on	the	PropertyManager.

Copy	Entities
The	Copy	 Entities	 tool	 is	 used	 to	 copy	 objects	 and	 place	 them	 at	 a	 required
location.	This	 tool	 is	 similar	 to	 the	Move	Entities	 tool,	 except	 that	object	will
remain	at	its	original	position	and	a	copy	of	it	will	be	placed	at	the	new	location.

1.	 Draw	two	circles	of	80	mm	and	140	mm	diameter,	respectively.



2.	 Click	 Sketch	 >	 Move	 Entities	 >	 Copy	 Entities	 on	 the
CommandManager.

3.	 Select	the	two	circles,	and	then	right-click	to	accept	the	selection.
4.	 Select	the	center	of	the	circle	as	the	base	point.

5.	 Move	the	pointer	toward	right	and	click.	

This	creates	a	copy	of	the	circles	at	the	new	location.

Scale	Entities
The	Scale	Entities	 tool	 changes	 the	 size	 of	 objects.	 It	 reduces	 or	 enlarges	 the
size	without	changing	the	shape	of	an	object.

1.	 Click	 Sketch	 >	 Move	 Entities	 >	 Scale	 Entities	 on	 the
CommandManager.

2.	 Select	the	circles	shown	below	and	right-click	to	accept	the	selection.

3.	 Select	the	center	point	of	the	selected	circles	as	the	base	point.



4.	 Type	 0.6	 in	 the	 Scale	 Factor	 box	 under	 the	 Parameters	 section	 of	 the
PropertyManager.

5.	 Uncheck	the	Copy	option	on	the	PropertyManager	and	click	OK.

6.	 Click	 Sketch	 >	 Circle	 drop-down	 >	 Perimeter	 Circle	 on	 the
CommandManager.

7.	 Select	the	two	circles	shown	below	to	define	the	tangent	points.

8.	 Move	the	pointer	down	and	click	to	create	the	circle.

9.	 Likewise,	create	another	circle	by	selecting	the	points	as	shown.



10.	 Click	Close	Dialog 	on	the	PropertyManager.

Trim	Entities
When	 an	 object	 intersects	 with	 another	 object,	 you	 can	 remove	 its	 unwanted
portion	by	using	the	Trim	Entities	tool.

1.	 Click	Sketch	>	Trim	Entities	 on	the	CommandManager.
2.	 On	the	PropertyManager,	click	the	Power	trim	 icon.
3.	 Press	 and	 hold	 the	 left	 mouse	 button	 and	 drag	 the	 pointer	 across	 the

unwanted	portions	of	the	circles	as	shown.



4.	 On	the	PropertyManager,	click	the	Trim	Closest	 icon.
5.	 Click	on	the	inner	portions	of	the	circles,	as	shown.

6.	 Click	Close	Dialog	 on	the	PropertyManager.
7.	 On	the	CommandManager,	click	Sketch	>	Arc	drop-down	>	3	Point	Arc

.
8.	 Select	three	points	in	the	graphics	window,	as	shown.



9.	 Create	other	arcs	using	the	3	Point	Arc	tool,	as	shown.

10.	 On	the	CommandManager,	click	Sketch	>	Trim	Entities .

11.	 On	the	PropertyManager,	click	the	Trim	away	inside 	icon.
12.	 Click	on	the	boundary	entities,	as	shown.
13.	 Click	on	the	entities	to	trim,	as	shown.

The	inner	portions	of	the	entities	are	trimmed.

14.	 Press	Ctrl+Z	twice	to	undo	the	trim	operations	(or)	click	Undo 	twice	on



the	Quick	Access	Toolbar.

15.	 Activate	the	Trim	Entities 	tool	and	click	the	Trim	away	outside	
icon	on	the	PropertyManager.

16.	 Click	on	the	boundary	and	trim	entities.	The	outer	portions	are	trimmed,	as
shown.

17.	 Undo	the	trim	operations.

18.	 Activate	the	Trim	Entities 	tool	and	click	the	Corner	 	icon	on	the
PropertyManager.

19.	 Click	on	the	intersecting	entities,	a	shown.

The	entities	are	trimmed	to	form	a	corner.



Extend	Entities
The	 Extend	 Entities	 tool	 is	 similar	 to	 the	 Trim	 Entities	 tool	 but	 its	 use	 is
opposite	of	 it.	This	 tool	 is	used	 to	extend	 lines,	arcs	and	other	open	entities	 to
connect	to	other	objects.

1.	 Create	a	sketch	as	shown	below.

2.	 Click	 Sketch	 >	 Trim	 Entities	 >	 Extend	 Entities	 on	 the
CommandManager.

3.	 Select	the	horizontal	open	line.	This	will	extend	the	line	up	to	arc.

Likewise,	extend	the	other	elements,	as	shown.



4.	 Trim	the	unwanted	portions.

Offset	Entities
The	Offset	Entities	tool	creates	parallel	copies	of	lines,	circles,	arcs	and	so	on.

1.	 On	the	CommandManager,	click	Sketch	tab	>	Offset	Entities .
2.	 Check	the	Select	Chain	option	on	the	PropertyManager	to	select	connected

elements.
3.	 Select	an	entity	and	notice	that	all	the	connected	entities	are	selected.
4.	 Type-in	the	offset	distance	on	the	PropertyManager.
5.	 Click	inside	or	outside	the	sketch	to	define	the	offset	side.



You	 can	 also	 reverse	 the	 offset	 direction	 by	 double-clicking	 on	 the	 offset
dimension	and	selecting	the	Reverse	the	sense	of	direction	button.

6.	 Create	a	line	chain	as	shown.

7.	 Activate	the	Offset	Entities	tool.
8.	 Select	a	line	segment	and	notice	that	entire	chain	is	selected.
9.	 Check	the	Bi-directional	option.	Notice	that	the	offset	preview	appears	on

both	sides.

10.	 Check	 the	 Cap	 ends	 option	 and	 select	 Arcs.	 Notice	 that	 the	 ends	 are
capped	with	arcs.

11.	 Check	 the	 Base	 geometry	 option	 under	 the	 Construction	 geometry
section	 and	 click	OK.	 The	 line	 chain	 is	 offset	 on	 both	 sides,	 and	 then
converted	into	construction	entity.



TUTORIAL	1
This	 tutorial	 teaches	 you	 to	 use	 Sketch	 Fillet,	 Sketch	 Chamfer,	 Mirror
Entities,	and	Tangent	Arc	tools.

Sketch	Fillet
The	Sketch	Fillet	tool	converts	the	sharp	corners	into	round	corners.

1.	 Draw	the	lines	as	shown	below.

2.	 Click	Sketch	>	Sketch	Fillet	 on	the	CommandManager.
3.	 On	the	PropertyManager,	type-in	a	value	in	the	Radius	box.
4.	 Click	on	the	corner,	as	shown.

5.	 Select	the	vertical	and	horizontal	lines,	as	shown.



The	Keep	constrained	corners	option	retains	all	the	existing	constraints.

The	Dimension	 each	 fillet	 option	 dimensions	 all	 the	 fillets	 created	 in	 single
instance.	If	you	uncheck	this	option,	only	a	single	fillet	is	dimensioned	and	the
Equal	relation	is	applied	between	all	other	fillets.

6.	 Click	 OK	 on	 the	 PropertyManager.	 The	 fillets	 are	 created.	 The	 Keep
visible	 icon	 on	 the	 PropertyManager	will	 keep	 it	 open.	You	 can	 select
other	corners	or	click	the	Close	icon.

Sketch	Chamfer
The	Sketch	Chamfer	 tool	 replaces	 the	sharp	corners	with	an	angled	 line.	This
tool	is	similar	to	the	Sketch	Fillet	tool,	except	that	an	angled	line	is	placed	at	the
corners	instead	of	rounds.

1.	 Click	 Sketch	 >	 Sketch	 Fillet	 >	 Sketch	 Chamfer	 on	 the
CommandManager.

2.	 On	the	PropertyManager,	select	the	Distance-distance	option	and	check	the
Equal	distance	option.



3.	 Type-in	a	value	in	the	Distance	box.

4.	 Click	on	the	corner	as	shown.

5.	 Click	OK	on	the	PropertyManager.

Mirror	Entities
The	Mirror	 Entities	 tool	 creates	 a	 mirror	 image	 of	 objects.	 You	 can	 create
symmetrical	sketches	using	this	tool.

1.	 Create	a	horizontal	centerline	passing	through	the	origin.



2.	 On	the	Command	Manager,	click	Sketch	>	Mirror	Entities .
3.	 Drag	a	selection	box	covering	all	the	sketch	entities.

4.	 On	 the	 PropertyManager,	 click	 in	 the	Mirror	 about	 box	 and	 select	 the
centerline	passing	through	the	origin.

5.	 Click	OK	to	mirror	the	selected	entities.

6.	 On	the	CommandManager,	click	Sketch	>	Arc	drop-down	>	Tangent	Arc
.

7.	 Select	the	start	point	of	the	arc	as	shown	below.

8.	 Move	the	pointer	and	select	the	end	point	of	the	arc,	as	shown	below.



9.	 Click	OK	on	the	PropertyManager.

Stretch	Entities
The	Stretch	Entities	 tool	 lengthens	or	 shortens	drawings	or	 parts	 of	 sketches.
Note	that	you	cannot	stretch	circles	using	this	tool.	In	addition,	you	must	select
the	portion	of	the	drawing	to	be	stretched	by	dragging	a	selection	box.

1.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Move	 Entities	 >	 Stretch
Entities .

2.	 Drag	a	crossing	window	to	select	the	objects	of	the	sketch,	as	shown.	Click
the	right	mouse	button.



Select	the	base	point	as	shown	below.

Move	the	pointer	toward	left	and	click	to	stretch	the	sketch.

Circular	Sketch	Pattern
The	Circular	Sketch	Pattern	 tool	 creates	 an	arrangement	of	objects	 around	a
point	in	circular	form.

1.	 Create	two	concentric	circles	of	140	and	50	diameters.



2.	 On	the	CommandManager,	click	Sketch	>	Arc	drop-down	>	Centerpoint
Arc .

3.	 Select	the	quadrant	point	of	the	circle	as	shown	below.

4.	 Move	the	pointer	down	and	click	on	the	circle	when	the	Coincident	symbol
appears.

5.	 Move	the	pointer	leftwards	and	up.
6.	 Click	on	the	circle	when	the	Coincident	symbol	appears.



7.	 Click	Close	Dialog	on	the	PropertyManager.
8.	 Dimension	the	arc	with	radius	30.

9.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Linear	 Sketch	 Pattern	 >
Circular	Sketch	Pattern .

10.	 Select	the	arc.	The	preview	of	the	circular	pattern	appears	as	the	center	of
the	pattern	is	selected,	automatically.

11.	 Leave	the	default	options	on	the	PropertyManager	and	click	OK.
12.	 Trim	the	unwanted	portions	as	shown	below.



Text
Texts	 are	 used	 to	 provide	 information	 on	 the	models	 such	 as	 company	 name,
model	specifications,	and	so	on.
	
1.	 Start	a	new	sketch.
2.	 Create	the	circle	and	two	lines	perpendicular	to	each	other,	as	shown.

3.	 On	the	Sketch	CommandManager,	click	the	Text	 tool.
4.	 Select	the	horizontal	line	as	the	supporting	curve.
5.	 Click	in	the	Text	box	in	the	PropertyManager	and	type	SOLIDWORKS.	On

the	 PropertyManager,	 use	 the	Alignment	 options	 (Left	 Align ,	Center
Align ,	Right	Align ,	and	Full	Justify )	to	change	the	alignment	of	the
text.	Use	 the	Flip	options	 (Flip	Vertical	 and	Flip	Horizontal)	 to	 the	 flip
the	text.



6.	 Click	 right	 mouse	 button	 in	 the	 Curve	 box	 and	 select	 the	 vertical
construction	line.

7.	 Select	the	text	from	Text	box	and	click	Rotate .
8.	 Change	the	rotation	angle	value	in	the	Text	box,	as	shown.

9.	 Right	click	in	the	Curve	box	and	select	Delete.
10.	 Select	the	circle	as	the	alignment	curve.
11.	 Select	the	rotation	angle	value	text	and	press.



12.	 Click	the	OK	on	the	PropertryManager.

3D	Sketch
3D	sketches	are	created	without	selecting	any	plane	and	sketch	elements	spread
over	the	3D	space	instead	of	a	single	plane.	However,	you	can	also	use	planes	to
create	3D	sketch.

1.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Sketch	 drop-down	 >	 3D
Sketch .

2.	 On	the	CommandManager,	click	Sketch	>	Line .
3.	 Select	the	origin	point	to	define	the	start	point.

4.	 Move	the	pointer	along	the	X-axis	and	click	to	create	a	line.

5.	 Move	the	pointer	along	the	Y-axis	and	click.



6.	 Press	the	Tab	key	to	change	the	plane.
7.	 Move	the	pointer	in	the	Z-direction	and	click.

8.	 Press	the	Tab	key	to	change	the	plane.
9.	 Move	the	pointer	in	the	X-direction	and	click.

10.	 Click	the	right	mouse	button	and	select	Select.
11.	 On	the	CommandManager,	click	Sketch	>	Plane .
12.	 Press	the	Ctrl	key	and	select	the	end	points	as	shown.



13.	 Click	OK	on	the	PropertyManager.

14.	 Activate	the	Line	tool	and	click	the	end	of	the	previous	line.
15.	 Move	 the	pointer	and	click	when	 the	Vertical	 symbol	appears	next	 to	 the

pointer.

16.	 Move	the	pointer	and	click	when	the	Horizontal	symbol	appears.



17.	 Click	the	right	mouse	button	and	select	Select.
18.	 Add	dimensions	and	relations,	and	then	click	Exit	Sketch.

	



Chapter	6:	Additional	Modeling	Tools

In	this	chapter,	you	construct	models	using	additional	modeling	tools.	You	will
learn	to:

Construct	Helixes
Add	Reference	Planes
Construct	Sweep	features
Construct	Revolved	Cuts
Mirror	Features
Construct	Loft	features
Create	multibody	parts
Add	Indent	Features
Shell	Models
Create	Helical	threads
Construct	rib	features
Insert	Holes
Create	Patterns



	TUTORIAL	1
In	 this	 tutorial,	 you	will	 construct	 a	 helical	 spring	 using	 the	Helix	 and	Sweep
Boss/Base	tools.



Constructing	the	Helix
1.	 Open	a	new	SOLIDWORKS	file	using	the	Part	template.
2.	 To	construct	a	helix,	click	Features	>	Curves	>	Helix	and	Spiral	on	 the

CommandManager.

3.	 Click	on	the	top	plane.
4.	 Draw	a	circle	of	diameter	30.

5.	 Click	Exit	Sketch	and	change	the	view	to	Isometric.



6.	 On	the	PropertyManager,	set	Pitch	to	10	mm.
7.	 Set	Revolutions	to	10.
8.	 Select	Clockwise.
9.	 Check	the	Taper	Helix	option	and	set	Taper	Angle	to	10.
10.	 Click	OK.

Adding	the	Reference	Plane
1.	 To	add	a	reference	plane,	click	Features	>	Reference	Geometry	>	Plane

on	the	CommandManager.

2.	 Select	the	helix	from	the	graphics	window.
3.	 Select	the	end	of	the	helix.



4.	 Leave	the	default	values	and	click	OK .

															
Constructing	the	Sweep	feature
1.	 On	the	CommandManager,	click	Sketch	>	Sketch .
2.	 Select	the	plane	created	normal	to	helix.
3.	 On	the	View	(Heads	Up)	Toolbar,	click	View	Orientation	>	Normal	To.

4.	 Draw	circle	of	4	mm	diameter.

														
5.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Display/Delete	 Relations	 >



Add	Relations .
6.	 Click	on	the	center	point	of	the	circle	and	helix.
7.	 On	the	PropertyManager,	under	the	Add	Relations	section,	select	Pierce.

8.	 Click	OK .

9.	 Click	Exit	Sketch	and	change	the	view	orientation	to	Isometric.

10.	 To	construct	a	sweep	feature,	click	Features	>	Sweep	Boss/Base	 on	the
CommandManager.

11.	 Select	the	circle	to	define	the	profile.
12.	 On	 the	PropertyManager,	 click	 in	 the	Path	 selection	box	and	select	 the

helix	to	define	the	path.
13.	 Leave	the	default	settings	and	click	OK	to	construct	the	sweep	feature.
14.	 On	the	View	Heads-Up	toolbar,	click	the	Visibility	drop-down	and	turn	off

the	Plane	and	Curves	icons.



														
15.	 Save	and	close	the	file.

	
You	need	 to	make	 sure	 that	 the	 size	of	 the	cross	 section	 is	not	 larger	 than	 the
curves	on	the	path,	the	resulting	geometry	will	intersect	and	the	sweep	will	fail.

	



In	SOLIDWORKS	2016,	you	can	create	a	profile	anywhere	along	the	path.	For
example,	create	a	profile	at	the	middle	of	the	path,	as	shown.	Activate	the	Sweep
tool	and	select	the	profile	and	path.	On	the	PropertyManager,	use	the	Direction
1 ,	Birectional ,	and	Direction	2	 icons	to	sweep	the	profile.

Direction	1

Direction	2

Birectional	



TUTORIAL	2
In	 this	 tutorial,	you	construct	a	pulley	wheel	using	 the	Revolve	Boss/Base	and
Revolved	Cut	tools.

														

1.	 Open	a	file	in	the	Part	Environment.
2.	 On	the	CommandManager,	click	Sketch	>	Sketch.
3.	 Click	on	the	right	plane.
4.	 On	the	CommandManager,	click	Sketch	>	Line	>	Centerline.
5.	 Construct	a	horizontal	centerline	passing	through	origin.
6.	 Construct	the	sketch,	as	shown	in	figure.

7.	 Add	dimensions	to	the	sketch.
8.	 Add	the	Coincident	relation	between	the	origin	and	the	vertical	line	at	the

center.



9.	 Construct	the	revolved	boss.

Constructing	a	Revolved	Cut
1.	 To	 construct	 a	 revolved	 cut,	 click	 Features	 >	 Revolved	 cut	 on	 the

CommandManager.
2.	 Expand	the	FeatureManager	Design	Tree	and	select	the	right	plane.
3.	 Under	the	FeatureManager	Design	Tree,	click	the	right	mouse	button	on

the	sketch	and	select	Normal	To.



4.	 On	the	CommandManager,	click	Sketch	>	Convert	Entities .
5.	 Click	on	the	horizontal	edge	of	the	model.	Click	OK.

6.	 Draw	the	sketch	entities	and	add	dimensions.	Trim	the	unwanted	entities.



7.	 Click	Exit	Sketch	and	click	OK.

Constructing	a	Mirror	Feature
1.	 To	 construct	 the	 mirror	 feature,	 click	 Features	 >	 Mirror	 on	 the

CommandManager.
2.	 Click	on	the	front	flat	face	to	define	the	mirror	face.

3.	 On	the	PropertyManager,	expand	the	Bodies	to	Mirror	section	and	click	on
the	model	geometry.

4.	 Click	OK.



5.	 Save	and	close	the	model.



TUTORIAL	3
In	this	tutorial,	you	construct	a	shampoo	bottle	using	the	Loft,	Extrude,	Shell,
Indent,	and	Sweep	tools.													

Creating	Sections	and	Guide	curves
To	construct	a	lofted	boss,	you	need	to	create	sections	and	guide	curves.

1.	 Open	a	new	file	in	the	Part	Environment.
2.	 On	the	CommandManager,	click	Sketch	>	Sketch.
3.	 Select	the	top	plane.
4.	 On	the	CommandManager,	click	Sketch	>	Ellipse .
5.	 Select	the	origin	point	of	the	sketch.
6.	 Move	the	pointer	horizontally	and	left	click.
7.	 Move	the	pointer	vertically	and	left	click.

8.	 Create	two	centerlines	passing	to	the	origin	and	perpendicular	to	each	other,
as	shown.



9.	 Activate	Smart	Dimension	 tool	and	add	dimensions	 to	 the	centerlines,	as
shown.

10.	 Click	Exit	Sketch.
11.	 Change	the	orientation	to	Isometric.
12.	 On	the	CommandManager,	click	Sketch	>	Sketch.
13.	 Select	the	front	plane.
14.	 On	the	CommandManager,	click	Sketch	>	Spline .
15.	 Draw	a	spline	similar	to	the	one	shown	in	figure.



16.	 Press	the	Ctrl	key	and	click	on	the	first	point	of	the	spline	and	the	previous
sketch.

17.	 On	the	PropertyManager,	under	the	Add	Relations	section,	click	Pierce.
18.	 Apply	 dimensions	 to	 the	 spline,	 as	 shown	 in	 figure.	 First,	 create	 the

horizontal	 dimensions,	 and	 then	 create	 the	 vertical	 dimensions	 in	 the
descending	order.

19.	 Draw	a	vertical	centerline	passing	through	the	sketch	origin.
20.	 On	the	CommandManager,	click	Sketch	>	Mirror	Entities .
21.	 Select	the	spline.
22.	 On	the	PropertyManager,	click	Mirror	about,	and	 then	select	 the	vertical

centerline.
23.	 Click	OK.

24.	 Click	Exit	Sketch.
25.	 Change	the	view	orientation	to	Isometric.



Creating	another	section
1.	 On	the	CommandManager,	click	Features	>	Reference	Geometry	>	Plane

.
2.	 Select	the	top	plane	from	FeatureManager	Design	Tree.
3.	 On	the	PropertyManager,	type-in	225	in	the	Offset	Distance	box.

4.	 Click	OK.
5.	 Start	a	sketch	on	the	new	reference	plane.
6.	 Draw	a	circle	of	40	mm	diameter.



7.	 Click	Exit	Sketch.
8.	 Change	the	view	to	Isometric.

Constructing	the	swept	feature
1.	 On	the	CommandManager,	click	Features	>	Lofted	Boss/Base .
2.	 Select	the	circle	and	ellipse.
3.	 On	the	PropertyManager,	click	in	the	Guide	Curves	selection	box	and	click

OK	on	the	box.

4.	 Select	the	second	guide	curve	and	click	OK	on	the	box.



5.	 Click	OK.

Constructing	the	Extruded	feature
1.	 In	 the	FeatureManager	Design	Tree,	 expand	 the	Loft	 feature	 and	 select

the	Sketch	3.



2.	 Press	 the	Ctrl	 key	 and	 select	 the	 reference	plane	 located	 at	 the	 top	of	 the
lofted	feature.

3.	 On	the	Menu	bar,	click	Insert	>	Derived	Sketch.

4.	 Click	Exit	Sketch.
5.	 Activate	 the	Extrude	Boss/Base	 tool	 and	 extrude	 the	 sketch	up	 to	25

mm	depth.

Adding	Fillets
1.	 On	the	CommandManager,	click	Features	>	Fillet .
2.	 On	the	PropertyManager,	click	the	FilletXpert	tab.
3.	 Click	on	the	bottom	and	top	edges	of	the	loft	feature.



4.	 Set	Radius	to	5	mm.

5.	 Click	OK	to	add	the	fillet.

Shelling	the	Model
1.	 On	the	CommandManager,	click	Features	>	Shell .
2.	 On	the	PropertyManager,	set	Thickness	to	2	mm.
3.	 Select	the	top	face	of	the	cylindrical	feature.



4.	 Click	OK	to	shell	the	geometry.

Adding	the	Indent	feature
1.	 On	the	CommandManager,	click	Features	>	Reference	Geometry	>	Plane

.
2.	 In	the	FeatureManager	Design	Tree,	select	the	Front	plane.



3.	 On	the	PropertyManager,	type-in	50	in	the	Distance	box.

4.	 Click	OK.

5.	 Create	a	sketch	on	the	plane,	as	shown	in	figure.

6.	 Click	Exit	Sketch.



7.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
8.	 Select	the	sketch.
9.	 On	 the	 PropertyManager,	 under	 the	 Direction1	 section,	 select	 End

Condition	>	Up	To	Surface.
10.	 On	the	PropertyManager,	under	Direction	1,	uncheck	Merge	result.

11.	 Rotate	the	model	and	select	the	inner	face	of	the	model	geometry.

12.	 Click	OK	to	create	separate	extruded	body.



13.	 On	the	Menu	bar,	click	Insert	>	Features	>	Indent.

14.	 Click	on	the	loft	feature	to	define	the	target	body.
15.	 Click	on	the	extruded	body	to	define	the	tool	body.
16.	 On	the	PropertyManager,	select	Remove	Selections.
17.	 Under	the	Parameters	section,	set	the	Thickness	value	to	2	and	Clearance

value	to	1.



18.	 Click	OK	to	indent	the	extruded	body	onto	the	lofted	body.
19.	 Hide	the	extruded	body,	sketch,	and	plane.

20.	 Add	1	mm	fillet	to	the	inner	and	outer	edges	of	the	indent.



Adding	Threads
1.	 On	the	CommandManager,	click	Features	>	Reference	Geometry	>	Plane

.
2.	 Click	on	the	top	face	of	the	model	geometry.
3.	 Set	the	Distance	value	to	5	and	check	the	Flip	offset	option.
4.	 Click	OK.

5.	 Start	sketch	on	the	new	reference	plane.
6.	 On	the	CommandManager,	click	Sketch	>	Convert	Entities .
7.	 Click	on	the	outer	edge	of	the	cylindrical	feature	and	click	OK.



8.	 Click	Exit	Sketch.
9.	 On	the	CommandManager,	click	Features	>	Curves	>	Helix	and	Spiral

.
10.	 Select	the	circular	sketch.
11.	 On	the	PropertyManager,	select	Constant	pitch.
12.	 Type-in	7	in	the	Pitch	box	and	check	the	Reverse	Direction	option.
13.	 Type-in	2	in	the	Revolutions	box.
14.	 Set	the	Start	Angle	value	to	0.
15.	 Uncheck	the	Taper	Helix	option.
16.	 Click	OK.

17.	 On	 the	 CommandManager,	 click	 Features	 >	 Reference	 Geometry	 >
Plane.

18.	 Click	on	the	helix	and	its	start	point.



19.	 Click	OK.
20.	 Start	a	sketch	on	the	new	reference	plane.
21.	 Draw	the	thread	profile.



22.	 Click	Exit	Sketch.

23.	 On	the	CommandManager,	click	Features	>	Swept	Boss/Base .
24.	 Click	on	the	thread	profile	and	the	helix.

25.	 On	 the	 PropertyManager,	 expand	 the	Options	 section	 and	 check	Merge
result.

26.	 Click	OK.



27.	 Start	a	sketch	on	the	end	face	of	the	thread.

28.	 On	 the	CommandManager,	 click	Sketch	>	Covert	Entities	 and	 select
the	thread	profile.

29.	 Click	OK.

30.	 Click	Exit	Sketch.
31.	 Activate	 the	Revolved	Boss/Base	 tool	and	click	on	 the	vertical	 line	of

the	sketch.
32.	 On	the	PropertyManager,	set	Direction	1	Angle	to	100.
33.	 Check	the	Merge	result	option.



34.	 Click	OK.
35.	 Rotate	the	model	and	click	on	the	other	end	of	the	thread.

36.	 Press	 the	 Ctrl	 key	 and	 select	 the	 sketch	 used	 for	 the	 previous	 revolved
feature.

37.	 On	the	Menu	bar,	click	Insert	>	Derived	Sketch.

38.	 On	 the	 CommandManager,	 click	 Display/Delete	 Relations	 >	 Add



Relations.
39.	 Click	 on	 the	 inclined	 line	 of	 the	 sketch	 and	 the	 inclined	 edge	 of	 the	 end

face.

40.	 On	the	PropertyManager,	click	Collinear.
41.	 Click	on	the	endpoints,	as	shown	in	figure.

42.	 On	the	PropertyManager,	click	Coincident.

43.	 Create	a	revolved	boss	using	the	sketch.



44.	 Save	the	model	and	close	it.



TUTORIAL	4
In	this	tutorial,	you	construct	a	patterned	cylindrical	shell.													

Constructing	a	cylindrical	shell
1.	 Start	a	new	file	using	the	Part	template.
2.	 Create	a	sketch	on	the	top	plane.

3.	 Extrude	the	sketch	up	to	100	mm	depth.



Adding	a	Slot
1.	 Activate	the	Extruded	Cut	 tool.
2.	 Click	on	the	front	plane.
3.	 On	the	CommandManager,	click	Sketch	>	Straight	Slot .
4.	 Click	to	define	the	first	point	of	the	slot.

5.	 Move	the	pointer	up	and	click	to	define	the	second	point.



6.	 Move	the	pointer	and	click	to	create	a	slot.
7.	 Add	dimensions	to	the	slot.

8.	 Click	Exit	Sketch.
9.	 On	the	PropertyManager,	select	End	Condition	>	Through	All.
10.	 Click	 the	Reverse	 Direction	 button	 next	 to	 the	End	 Condition	 drop-

down.

11.	 Click	OK.

Constructing	the	Axis



1.	 On	the	CommandManager,	click	Features	>	Reference	Geometry	>	Axis
.

2.	 Click	on	the	inner	cylindrical	face	of	the	model	geometry.

3.	 Click	OK	to	construct	the	axis.

Constructing	the	Linear	pattern
1.	 On	the	CommandManager,	click	Features	>	Linear	Pattern .
2.	 On	 the	PropertyManager,	 under	 the	Features	 and	Faces	 section,	 click	 in

the	Features	to	Pattern	box,	and	then	select	the	slot.
3.	 In	the	FeatureManager	Design	Tree,	select	the	newly	created	axis.	You	can

also	select	the	Top	Plane	from	the	FeatureManager	Design	Tree.

4.	 On	 the	 PropertyManager,	 under	 the	Direction1	 section,	 set	 the	 Spacing
value	to	16.

5.	 Set	Number	of	Instances	to	6.



6.	 Click	OK.

Constructing	the	Circular	pattern
1.	 On	 the	CommandManager,	 click	Features	 >	Linear	Pattern	 >	Circular

Pattern .
2.	 In	 the	FeatureManager	Design	Tree,	 select	 the	 linear	 pattern	 and	 the	 cut-

extrude	feature.

3.	 On	the	PropertyManager,	click	in	the	Pattern	Axis	selection	box	and	select
the	cylindrical	face	of	the	model.



4.	 Type-in	12	in	the	Number	of	Instances	box.
5.	 Check	the	Equal	Spacing	option.55
6.	 Click	OK	to	make	the	circular	pattern.

11.	 Save	and	close	the	model.

															



TUTORIAL	5
In	this	tutorial,	you	construct	the	model	shown	in	figure.													

Constructing	the	first	feature
1.	 Open	a	new	part	file.
2.	 Construct	 the	 first	 feature	 on	 the	 top	 plane	 (extrude	 the	 sketch	 up	 to	 a

distance	of	10	mm).

Constructing	the	Second	Feature
1.	 Draw	the	sketch	on	the	top	face	of	the	first	feature.

2.	 Click	Exit	Sketch.
3.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
4.	 Type-in	45	in	the	Depth	box.



5.	 Click	OK.

Constructing	the	third	feature
1.	 On	 the	 CommandManager,	 click	 Features	 >	 Reference	 Geometry	 >

Plane.
2.	 Click	on	the	right-side	face	of	the	model	geometry.

3.	 Click	on	the	left-side	face	of	the	second	feature.



4.	 Click	OK.
5.	 Draw	the	sketch	on	the	new	reference	plane.

6.	 Click	Exit	Sketch.
7.	 On	the	CommandManager,	click	Features	>	Rib .
8.	 On	the	PropertyManager,	click	Thickness	>	Both	Sides .
9.	 Set	Rib	Thickness	to	10.
10.	 Select	Extrusion	direction	>	Parallel	to	Section .
11.	 Check	the	Flip	material	side	option.
12.	 Click	OK.



Inserting	Holes
1.	 To	 insert	 holes,	 click	 Features	 >	 Hole	 Wizard 	 on	 the

CommandManager.
2.	 On	the	Hole	Specification	PropertyManager,	select	the	Hole	 icon.
3.	 Select	Standard	>	ANSI	Metric.
4.	 Select	Type	>	Drill	Sizes.
5.	 Under	the	Hole	Specifications	section,	select	Size	>	16.
6.	 Select	End	Condition	>	Through	All.
7.	 Click	the	Positions	tab	and	click	on	the	top	face	of	the	base	feature.
8.	 Place	two	holes	on	the	top	face.

9.	 Add	dimensions	to	define	the	hole	location.



10.	 Click	OK.

11.	 Insert	another	hole	on	the	front	face	of	the	second	feature.



Adding	Chamfers
1.	 To	 add	 a	 chamfer,	 click	 Features	 >	 Fillet	 Chamfer	 on	 the

CommandManager.
2.	 On	the	PropertyManager,	select	Distance	distance.
3.	 Type-in	45	and	25	in	the	Distance	1	and	Distance	2	boxes.
4.	 Click	on	the	corner	edge	of	the	first	feature.

5.	 Click	OK	to	add	the	chamfer.

6.	 Activate	the	Chamfer	tool.
7.	 On	the	PropertyManager,	select	Angle	distance.
8.	 Type-in	45	in	the	Distance	and	Angle	boxes.
9.	 Click	on	the	corner	edge	of	the	second	feature.

10.	 Click	OK.





TUTORIAL	6
In	this	tutorial,	you	create	the	model	shown	in	figure.

Constructing	the	first	feature
1.	 Open	a	new	part	file.
2.	 On	the	CommandManager,	click	Features	>	Extruded	Boss/Base .
3.	 Click	on	the	top	plane.
4.	 Construct	two	circles	and	add	dimensions	to	them.

5.	 On	the	CommandManager,	click	Sketch	>	Trim	Entities	 and	trim	the
intersecting	entities.

6.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Sketch	 Fillet	 and	 set	 the
Fillet	Radius	value	to	10.



7.	 Select	the	intersecting	corners	of	the	circles,	and	then	click	OK.

8.	 Click	Exit	Sketch.
9.	 On	the	PropertyManager,	type	5	in	the	Depth	box.
10.	 Check	the	Thin	Feature	option	and	select	Type	>	One	Direction.
11.	 Type	20	in	the	Thickness	box.
12.	 Use	the	Reverse	Direction	 button	next	to	the	Type	drop-down	to	make

sure	that	the	extruded	feature	is	thickened	from	inside.
13.	 Click	OK.

Constructing	the	Extruded	cut
1.	 On	the	CommandManager,	click	Features	>	Extruded	Cut .
2.	 Click	on	the	top	face	of	the	model	geometry.
3.	 On	the	CommandManager,	click	Sketch	>	Polygon .
4.	 On	the	PropertyManager,	type-in	6	in	the	Number	of	Sides	box.
5.	 Select	the	Inscribed	circle	option.
6.	 Click	to	define	the	center	point	of	the	polygon.



7.	 Move	the	pointer	and	click	to	construct	the	polygon.
8.	 Draw	a	horizontal	centerline	connecting	the	center	point	of	the	polygon	and

sketch	origin.

9.	 On	 the	 CommandManager,	 click	 Sketch	 >	 Display/Delete	 Relations	 >
Add	Relation.

10.	 Click	on	the	horizontal	line	of	the	polygon.



11.	 On	the	PropertyManager,	click	Horizontal,	and	then	click	OK.
12.	 Add	dimensions	to	the	sketch.

13.	 Click	Exit	Sketch.
14.	 Create	the	cut	throughout	the	body.

Making	the	Curve	Driven	Pattern
1.	 On	 the	 CommandManager,	 click	 Features	 >	 Linear	 Pattern	 >	 Curve

Driven	Pattern .

2.	 In	 the	 FeatureManager	 Design	 Tree,	 select	 the	 sketch	 used	 to	 create
Extrude-Thin1.



3.	 Select	the	polygonal	cut	to	define	the	feature	to	pattern.
4.	 Type-in	10	in	the	Number	of	Instances	box.
5.	 Check	the	Equal	Spacing	option.

6.	 Set	Curve	method	to	Offset	Curve.
7.	 Set	Alignment	method	to	Tangent	to	curve.
8.	 Click	OK.

9.	 Save	and	close	the	file.



TUTORIAL	7
In	this	tutorial,	you	create	a	bolt.

Start	a	new	part	file
1.	 Start	a	new	part	file	using	the	Part	template.
2.	 Construct	a	cylindrical	feature	of	20	mm	diameter	and	75	mm	length.

Creating	the	second	feature
1.	 Start	a	sketch	on	the	left	face	of	the	cylinder.
2.	 On	the	CommandManager,	click	Sketch	>	Polygon.
3.	 Create	a	hexagon	and	dimension	it	as	shown.

4.	 Exit	the	sketch.
5.	 Extrude	the	sketch	up	to	12	mm	depth.



Adding	Cosmetic	Threads
1.	 On	the	CommandManager,	click	Features	>	Hole	>	Thread .
2.	 Click	on	the	right	circular	edge	of	the	model	geometry.
3.	 Select	End	Condition	>	Blind	and	type-in	40	in	the	Distance	box.
4.	 On	the	PropertyManager,	select	Type	>	Metric	Die.
5.	 Select	Size	>	M20x1.5.
6.	 Click	the	Override	Diameter	 	icon	below	the	Size	drop-down.	This	will

enable	you	to	override	the	thread	diameter.
7.	 Click	OK	to	add	the	thread.
8.	 Save	the	file	as	Tutorial7.sldprt.

Creating	Configurations	Table
Configurations	Table	allows	you	to	design	a	part	with	different	variations,	sizes,
materials	 and	 other	 attributes.	Now,	 you	will	 create	 different	 variations	 of	 the
bolt	created	in	the	previous	section.

1.	 Click	 the	Configurations	 tab	 on	 the	 left-side	 of	 the	window.	Notice	 that
there	is	only	one	configuration	available	in	the	tree.



2.	 Click	the	FeatureManager	Design	Tree	 tab.
3.	 In	 the	FeatureManager	Design	Tree,	expand	Boss-Extrude1	 and	click	 the

right	mouse	button	on	Sketch1.
4.	 Select	Configure	Feature	from	the	shortcut	menu.

5.	 On	 the	 Modify	 Configurations	 dialog,	 click	 the	 down-arrow	 next	 to
Sketch1	 and	 check	 D1.	 Click	 on	 the	 dialog	 to	 display	 the	 Diameter
dimension.

6.	 On	 the	Modify	 Configurations	 dialog,	 click	 the	 right	 mouse	 button	 on
Sketch1	and	select	Rename.

7.	 Type-in	 Bolt	 Diameter	 and	 right-click	 on	 the	Modify	 Configurations
dialog.

8.	 On	 the	 Modify	 Configurations	 dialog,	 click	 in	 the	 <	 Creates	 a	 new
configuration.	 >	 cell	 and	 type-in	 Small	 Diameter.	 Click	 on	 the	 table	 to



create	a	new	configuration.

9.	 Type	12	in	the	D1	cell	of	Small	Diameter	configuration.

10.	 In	 the	 FeatureManager	 Design	 Tree,	 double-click	 on	 Thread1,	 Boss-
Extrude2,	and	Sketch2	to	add	them	to	the	table.

11.	 On	 the	Modify	 Configurations	 dialog,	 click	 the	 right	 mouse	 button	 on
Boss-Extrude2	column	and	select	Delete.	The	column	is	removed	from	the
table.

12.	 Add	the	dimensions	of	Thread1	and	Sketch2	by	clicking	the	down-arrows
next	to	columns	and	checking	the	dimensions.

13.	 Modify	the	D6	value	of	Thread1	for	Small	Diameter	configuration	to	12.
14.	 Modify	 the	D1	 value	 of	 the	 Sketch2	 for	 Small	Diameter	 configuration	 to

20.

15.	 On	 the	Modify	Configurations	 dialog,	 type-in	Custom	Table	 in	 the	box
located	at	the	bottom,	and	then	click	the	Save	table	view	button	next	to	it.



16.	 Click	OK	to	close	the	dialog.
17.	 Click	 the	 Configurations	 tab	 on	 the	 left-side	 pane	 and	 notice	 two

configurations	along	with	a	configurations	table.

18.	 Click	 the	 right	 mouse	 button	 on	 the	 Small	 Diameter	 configuration	 and
select	Show	Configuration.

19.	 To	 edit	 the	 configuration	 table,	 click	 the	 right	 mouse	 button	 on	Custom
Table	and	select	Show	Table.	The	Modify	Configurations	dialog	appears.
Change	the	values	or	create	new	configurations,	and	then	click	the	Save	the
table	view	 icon.

20.	 Save	as	Configurations	Table.sldprt	and	close	the	file.

TUTORIAL	8
In	this	tutorial,	you	create	a	plastic	casing.



																					 		
Creating	the	First	Feature
1.	 Open	a	new	Part	file.
2.	 Create	a	sketch	on	the	Top	Plane,	as	shown	in	figure.

																				 		
3.	 Click	Exit	Sketch.
4.	 Click	the	Features	>	Extruded	Boss/Base	 on	the	CommandManager.
5.	 Set	the	Distance	to	40.
6.	 Click	the	Draft	on/off	 icon	and	set	the	Draft	Angle	to	10.
7.	 Click	OK.

Creating	the	Extruded	surface



1.	 On	 the	 CommandManager,	 click	 the	 right	mouse	 on	 anyone	 of
the	tabs	and	select	Surfaces.

2.	 Click	 Surfaces	 >	 Extruded	 Surface	 on	 the
CommandManager	and	select	the	Right	Plane.

3.	 On	 the	 View	 Heads	 up	 toolbar,	 click	 View	 Orientation	 >
Normal	To .

4.	 Click	Sketch	>	Spline 	on	the	CommandManager.

5.	 Create	a	spline,	as	shown	in	figure.

6.	 Apply	dimensions	to	the	spline,	as	shown	below.

														 		
7.	 Click	Exit	Sketch.
8.	 Set	the	End	Condition	type	to	Mid	Plane.
9.	 Extrude	the	sketch	up	to	215	mm	depth.



Replacing	the	top	face	of	the	model	with	the	surface
1.	 On	the	CommandManager,	click	Surfaces	>	Replace	Face .

Now,	you	need	to	select	the	face	to	be	replaced.
															
2.	 Select	the	top	face	of	the	model.

Next,	you	need	to	select	the	replacement	face	or	surface.
																	
3.	 Click	 in	 the	 Replacement	 Face(s)	 box	 on	 the	 PropertyManager	 and

select	the	extruded	surface.
4.	 Click	OK	to	replace	the	top	face	with	a	surface.

5.	 Hide	the	extruded	surface	by	clicking	on	it	and	selecting	Hide .



Creating	a	Face	fillet
1.	 On	 the	 CommandManager,	 click	 the	 Fillet	 icon	 on	 the

Features	tab.
2.	 On	the	PropertyManager,	click	the	Manual	tab.

3.	 Click	the	Face	Fillet	 button	on	the	Fillet	PropertyManager.
4.	 Select	the	top	surface	as	the	first	face.
5.	 On	the	PropertyManager,	click	 in	 the	Face	Set	2	box	and	select

the	inclined	front	face	as	the	second	face.

6.	 On	 the	 PropertyManager,	 under	 the	 Fillet	 Parameters	 section,
select	Symmetric	from	the	drop-down	and	type	20	in	the	Radius
box.	Click	OK	to	create	the	face	fillet.



7.	 Likewise,	apply	a	face	fillet	of	20	mm	radius	between	top	surface
and	the	back	inclined	face	of	the	model.

																					
Creating	a	Variable	Radius	fillet

1.	 Click	the	Fillet	icon	on	the	Features	tab.

2.	 Click	 the	 Variable	 Size	 Fillet	 icon	 on	 the	 Fillet
PropertyManager.

3.	 Click	the	right	mouse	button	on	the	curved	edge	and	select	Select
Tangency.

4.	 Modify	the	radii	values	in	callouts	as	shown.



					
6.	 Make	sure	the	Smooth	transition	option	is	checked	under	the	Profile	drop-

down.
7.	 Click	OK	to	create	the	variable	fillet.

																				 																
8.	 Create	a	variable	fillet	on	other	curved	edge	as	shown.

Shelling	the	Model
1.	 Click	the	Shell 	icon	on	the	Features	tab.

2.	 On	the	PropertyManager,	type	2.5	mm	in	the	Thickness	box.



3.	 Change	the	orientation	of	the	model	and	select	the	bottom	face.

4.	 Click	OK.

																	
Creating	the	Mounting	Bosses
1.	 On	the	CommandManager,	click	Features	>	Reference	Geometry	>	Axis

.
2.	 Press	 the	 Ctrl	 key	 and	 select	 the	 Right	 and	 Front	 planes	 from	 the

FeatureManager	Design	Tree.

3.	 Click	OK	on	the	PropertyManager.
4.	 Click	Insert	>	Fastening	Feature	>	Mounting	Boss	 on	 the	Menu	bar

and	select	the	inside	of	top	surface.



5.	 Click	 in	 the	Select	Direction	 box	 on	 the	PropertyManager	 and	 select	 the
Axis	from	the	FeatureManager	Design	Tree.

6.	 Click	the	Reverse	Direction 	icon	next	to	the	Select	Direction	box,	if	the
mounted	boss	appears	upwards.

7.	 Set	the	Boss	Type	to	Hardware	Boss.

8.	 Select	the	Thread	 icon.
9.	 In	the	Boss	section,	select	Select	mating	face.
10.	 Select	the	bottom	face	of	the	model	geometry.

11.	 Specify	the	parameters	in	the	Boss	section	as	shown.



12.	 Specify	the	parameters	in	the	Fins	section,	as	shown.

13.	 In	the	Favorite	section,	click	the	Add	or	update	a	favorite	 icon.
14.	 Type	Favorite1	in	the	Add	or	Update	a	Favorite	dialog	and	click	OK.
15.	 Click	OK	on	the	PropertyManager	to	create	the	boss.

16.	 In	 the	 FeatureManager	Design	Tree,	 expand	Mounting	Boss1	 and	 notice
that	a	3D	sketch	is	created.



17.	 Select	3DSketch1	and	click	Edit	Sketch.

18.	 Press	the	Ctrl	key	and	select	the	points	as	shown.

19.	 Click	the	Coincident	icon	on	the	PropertyManager,	and	click	OK.
20.	 Click	Exit	Sketch.	The	position	of	the	mounting	boss	is	changed.

21.	 Likewise,	create	other	mounting	bosses	as	shown.



Creating	the	Vent	Feature
1.	 Create	a	sketch	on	the	front	inclined	face.

																					
2.	 Click	Exit	Sketch.
3.	 On	the	Menu	bar,	click	Insert	>	Fastening	Feature	>	Vent .
4.	 Select	the	four	lines	of	the	rectangle	to	define	the	boundary.

																							
5.	 Click	in	the	Ribs	selection	box	and	select	the	two	horizontal	lines.
6.	 Set	the	rib	parameters,	as	shown	below.



																	 		

7.	 Click	OK	to	create	the	vent.

																				

8.	 Save	the	model	as	Plastic	cover.sldprt	and	close	it.



Chapter	7:	Sheet	metal	Modeling

This	chapter	will	show	you	to:
Construct	Base	Flange
Construct	Edge	Flange
Construct	Miter	Flange
Close	Corners
Apply	Corner	Treatments
Add	Tab	features
Add	Jogs
Unfold	and	refold	the	bends
Cut	across	bends
Perform	Forming	Operations
Add	Hems
Add	Vents
Add	Gussets
Make	Fill	Patterns
View	Flat	Pattern	

TUTORIAL	1

In	this	tutorial,	you	construct	the	sheet	metal	model	shown	in	figure.



Opening	a	New	File
	

1.	 Open	a	new	part	file.
2.	 On	 the	CommandManager,	click	 the	 right	mouse	button	on	anyone	of	 the

tabs	and	select	Sheet	Metal,	if	the	Sheet	Metal	tab	is	displayed.

The	Sheet	Metal	tab	appears.

Constructing	the	Base	Flange
	

1.	 To	 construct	 a	 base	 flange,	 click	Sheet	Metal	>	Base	Flange/Tab	 on



the	CommandManager.
2.	 Select	the	front	plane.
3.	 Construct	the	sketch,	as	shown.

4.	 Click	Exit	Sketch.
5.	 On	 the	 PropertyManager,	 under	Direction	 1	 section,	 type-in	 150	 in	 the

Depth	box.
6.	 Check	the	Use	gauge	table	option.
7.	 Select	SAMPLE	TABLE	–ALUMINIUM-METRIC	UNITS.
8.	 On	 the	 PropertyManager,	 under	 the	 Sheet	 Metal	 Parameters	 section,

select	Gauge	14.
9.	 Set	the	Bend	Radius	value	to	2.
10.	 Leave	the	Auto	Relief	section	to	default	settings.
11.	 Click	OK	to	construct	the	base	flange.

Adding	an	Edge	flange
	

1.	 To	 add	 the	 flange,	 click	 Sheet	 Metal	 >	 Edge	 Flange	 on	 the
CommandManager.

2.	 Select	the	edge	on	the	top	face.



														
3.	 Move	the	pointer	upward	and	click.
4.	 On	the	PropertyManager,	under	the	Flange	Length	section,	set	Length	 to

100.
5.	 Click	on	 the	 Inner	Virtual	Sharp	 icon	 in	 the	Flange	Length	 section.

This	measures	the	flange	length	from	the	outer	face.
6.	 Under	the	Flange	Position	section,	click	the	Material	Outside 	icon.
7.	 Click	OK	to	add	the	flange.

In	SOLIDWORKS	2016,	you	can	use	the	Edit	Flange	Profile	button	to	change
the	shape	of	the	flange.	The	sketch	mode	is	activated	when	you	click	this	button.
Use	the	sketch	tools	to	change	the	flange	shape.



Constructing	the	Miter	Flange
	

1.	 To	construct	the	miter	flange,	click	Sheet	Metal	>	Miter	Flange	 on	the
CommandManager.

2.	 Click	the	top	edge	left	flange.

3.	 Draw	the	sketch,	as	shown.



													

4.	 Click	Exit	Sketch.
5.	 Click	on	the	vertical	edge	of	the	left	flange.

6.	 On	 the	 Miter	 Flange	 PropertyManager,	 set	 the	 Flange	 Position	 to
Material	Inside	 and	Gap	distance	to	1.25.

7.	 Under	the	Start/End	Offset	section,	set	the	Start	Offset	Distance	and	End
Offset	Distance	to	10.

8.	 Click	OK	to	construct	the	miter	flange.



Closing	the	Corners	
	

1.	 To	close	the	corners,	click	Sheet	Metal	>	Corners	>	Closed	Corner .
2.	 Select	the	corner	face	of	the	miter	flange.

3.	 On	the	PropertyManager,	set	the	Corner	type	to	Butt .
4.	 Rotate	the	model	and	select	the	other	corner	faces.

5.	 Click	OK	 to	close	the	corners.
	

Adding	Corner	Reliefs
1.	 To	 add	 corner	 reliefs,	 click	Sheet	Metal	 >	Corners	 >	Corner	Relief .

This	selects	the	entire	part.
2.	 On	 the	 PropertyManager,	 under	 the	 Corners	 section,	 click	 Collect	 all

corners.

3.	 Under	the	Relief	Options	section,	set	the	Relief	type	Circular .



4.	 Type	2	in	the	Slot	Width	box.
5.	 Click	OK	to	add	the	corner	relief.

The	different	types	of	the	reliefs	are:



	
Adding	a	Tab	feature
1.	 To	 add	 a	 tab,	 click	 Sheet	 Metal	 >	 Base	 Flange/Tab	 on	 the

CommandManager.
2.	 Click	on	the	right	side	of	the	base	flange.

	



3.	 On	the	CommandManager,	click	Sketch	>	Line.
4.	 Click	on	the	vertical	edge	of	the	face	and	move	the	pointer	toward	left.
5.	 Again,	click	to	draw	a	horizontal	line.

6.	 Move	the	pointer	toward	endpoint	of	the	line.	The	arc	mode	gets	active.

7.	 Move	the	pointer	toward	left,	and	then	downwards.
8.	 Click	to	create	an	arc.



9.	 Close	the	sketch	and	add	dimensions.

10.	 Exit	the	sketch	and	click	OK	on	the	PropertyManager.

Adding	a	Jog
1.	 To	add	a	jog,	click	Sheet	Metal	>	Jog	 on	the	CommandManager.
2.	 Click	on	the	tab	face	and	draw	a	line.



3.	 Click	Exit	Sketch.
4.	 Click	on	the	base	flange	to	define	the	fixed	face.

5.	 On	 the	 PropertyManager,	 under	 the	 Jog	 Offset	 section,	 set	 the	 Offset
Distance	to	20.

6.	 Set	the	Dimension	position	to	Outside	Offset	 .
7.	 Set	the	Jog	Position	to	Bend	Centerline .
8.	 Set	the	Jog	Angle	to	75.
9.	 Click	OK.



Unfolding	the	bends
1.	 To	unfold	a	bend,	click	Sheet	Metal	>	Unfold .
2.	 Click	on	the	tab	face	to	define	the	fixed	face.
3.	 Click	on	the	bends	of	the	jog	feature.

4.	 Click	OK.

Creating	Cuts	across	bends
1.	 To	create	cuts	across	bends,	click	Sheet	Metal	>	Extruded	Cut	 on	the

CommandManager.



2.	 Click	on	the	tab	and	draw	the	sketch,	as	shown.

3.	 Click	Exit	Sketch.
4.	 Set	the	End	Condition	to	Up	To	Next.
5.	 Click	OK	on	the	PropertyManager.

Folding	the	Unfolded	bends
1.	 To	 fold	 the	 unfolded	 bends,	 click	 Sheet	 Metal	 >	 Fold	 on	 the

CommandManager.
2.	 Click	on	the	jog	bends.



3.	 Click	OK.

Performing	the	Forming	Operations
1.	 To	perform	forming	operations,	click	Design	Library	on	the	Task	pane.

2.	 If	the	Design	Library	is	not	displayed,	click	Add	File	Location .
3.	 Browse	 to	 the	 location:	 C:\ProgramData\SolidWorks\SOLIDWORKS



2016\design	library
4.	 Click	OK.
5.	 In	the	Design	Library,	click	the	right	mouse	button	on	the	forming	tools

folder	and	select	Forming	Tools	Folder.
6.	 Click	Yes	on	the	SOLIDWORKS	message	box.

7.	 Double-click	on	the	Louvers	folder.

8.	 Click	and	drag	the	Louver	onto	the	flange	face.

9.	 On	the	PropertyManager,	type-in	90	in	the	Rotation	Angle	box.
10.	 Under	the	Link	section,	uncheck	the	Link	to	form	tool	option.
11.	 Under	 the	Flat	Pattern	Visibility	 section,	check	 the	Override	document

settings	option.
12.	 On	 the	 PropertyManager,	 click	 the	 Position	 tab	 and	 add	 dimensions	 to



position	the	louver.

13.	 Click	OK.

Making	the	Linear	Pattern
	

1.	 On	the	CommandManager,	click	Features	>	Linear	Pattern .
2.	 Click	on	the	horizontal	edge	of	the	flange	to	define	the	first	direction.
3.	 On	 the	PropertyManager,	under	 the	Direction	1	 section,	 type-in	50	 in	 the

Spacing	box	and	2	in	the	Number	of	Instances	box.
4.	 Click	the	Reverse	Direction	 button.
5.	 Click	 on	 the	 vertical	 edge	 of	 the	 flange	 feature	 to	 define	 the	 second

direction.
6.	 Under	the	Direction	2	section,	type-in	20	in	the	Spacing	box	and	4	in	the

Number	of	Instances	box.
7.	 Select	the	louver	feature.



8.	 Click	OK	to	construct	the	pattern.

Adding	a	Hem
1.	 To	add	a	hem,	click	Sheet	Metal	>	Hem	 on	the	CommandManager.
2.	 Click	on	the	inner	edge	of	the	right	side	flange.

3.	 On	 the	 PropertyManager,	 under	 the	 Type	 and	 Size	 section,	 click	 the
Closed 	icon.

4.	 Type-in	15	in	the	Length	box.
5.	 Click	OK	to	add	the	hem.



Adding	a	vent
1.	 Construct	a	sketch	on	the	right	side	face	of	the	base	flange.

2.	 Click	Exit	Sketch.
3.	 On	the	CommandManager,	click	Sheet	Metal	>	Vent .
4.	 Click	on	 the	outer	most	circle	of	 the	sketch	 to	define	 the	boundary	of	 the

vent.

5.	 On	 the	 PropertyManager,	 click	 in	Ribs	 selection	 box	 and	 select	 the	 line
segments	from	the	sketch.

6.	 Type-in	2	in	the	Width	box.
7.	 Click	in	the	Spars	selection	box	and	select	the	two	middle	circles.



8.	 Type-in	2	in	the	Width	box.
9.	 Click	 in	 the	 Fill-In	 Boundary	 selection	 box	 and	 select	 the	 inner	 most

circle.
10.	 Click	OK.

Adding	Sheet	Metal	Gussets
1.	 To	 add	 gussets,	 click	 Sheet	 Metal	 >	 Sheet	 Metal	 Gusset	 on	 the

CommandManager.
2.	 Click	on	the	left	side	bend	face	of	the	base	flange.
3.	 On	the	PropertyManager,	under	the	Position	section,	set	the	Offset	value	to

30.
4.	 Under	the	Profile	section,	set	the	Indent	depth	to	12.
5.	 Click	the	Rounded	gusset	 icon.
6.	 Under	the	Dimensions	section,	set	the	Indent	Width	value	to	10.
7.	 Set	Indent	Thickness	to	2.
8.	 Set	Side	face	draft	to	2.
9.	 Set	Inner	corner	fillet	and	Outer	corner	fillet	to	1	and	2,	respectively.

10.	 Click	OK.



11.	 Make	a	linear	pattern	of	the	gusset.

12.	 Mirror	the	gusset	and	the	linear	pattern	about	the	right	plane.



Making	a	Fill	Pattern
	

1.	 Draw	a	sketch	on	the	top	face	of	the	base	flange.

2.	 Click	Exit	Sketch.
3.	 To	make	a	fill	pattern,	click	Features	>	Linear	Pattern	>	Fill	Pattern	

on	the	CommandManager.
4.	 Select	the	sketch	to	define	the	fill	boundary.
5.	 On	 the	 PropertyManager,	 under	 the	 Features	 and	 Faces	 section,	 select

Create	seed	cut	and	select	the	Polygon	icon.
6.	 Set	the	options	in	the	Features	and	Faces	section,	as	shown.



7.	 Under	the	Pattern	Layout	section,	select	the	Perforation	button.
8.	 Type-in	8	in	the	Instance	Spacing	box.
9.	 Set	Stagger	Angle	to	46.
10.	 Set	Margins	to	1.

11.	 Click	OK	to	make	the	fill	pattern.



12.	 Mirror	the	fill	pattern	about	the	right	plane.

	View	the	Flat	Pattern
1.	 To	 view	 the	 flat	 pattern,	 click	 Sheet	 Metal	 >	 Flatten	 on	 the

CommandManager.

													
2.	 									Again,	click	the	Flatten	button	to	switch	back	to	the	model	view.



3.	 Save	the	sheet	metal	part.



Chapter	8:	Top-Down	Assembly

															
															
In	this	chapter,	you	will	learn	to

Create	a	top-down	assembly
Insert	fasteners	using	Toolbox
Create	advanced	mates

TUTORIAL	1
In	 this	 tutorial,	 you	will	 create	 the	model	 shown	 in	 figure.	You	 use	 top-down
assembly	approach	to	create	this	model.

		
Creating	a	New	Assembly	File

1.	 Click	 the	New	 icon	 on	 the	 Quick	 Access	 Toolbar,	 select	 the
Assembly	icon,	and	click	OK.

2.	 Click	Cancel	 on	the	Begin	Assembly	PropertyManager.

Creating	a	component	in	the	Assembly
In	 a	 top-down	 assembly	 approach,	 you	 create	 components	 of	 an	 assembly



directly	in	the	assembly	by	using	the	New	Part	tool.
															
1.	 On	the	CommandManager,	click	Assembly	>	Insert	Components	>	New

Part .
2.	 In	 the	 FeatureManager	Design	Tree,	 click	 the	 Front	 plane.	A	 new	part	 is

created	and	the	Edit	Component	mode	is	activated.
3.	 Click	Exit	Sketch.
4.	 Click	Sketch	 >	 Sketch	 on	 the	 CommandManager	 and	 select	 the	 Top

plane	from	the	FeatureManager	Design	Tree.
5.	 Create	the	sketch	as	shown	below.

6.	 Click	Exit	Sketch.
7.	 Click	Features	>	Extruded	Boss/Base	 on	 the	CommandManager	and

extrude	the	sketch	up	to	40	mm.

		
8.	 Start	a	sketch	on	the	top	face	and	draw	a	circle	of	50	mm	diameter.



																					 		
9.	 Click	Exit	Sketch
10.	 Extrude	the	sketch	up	to	95	mm	distance.

11.	 On	the	CommandManager,	click	Features	>	Hole	Wizard .

12.	 On	the	PropertyManager,	click	the	Legacy	Hole	 icon.
13.	 On	the	PropertyManager,	select	Type	>	Counterbored.
14.	 In	the	Section	Dimensions	section,	modify	the	dimensions	as	shown.

15.	 Set	the	End	Condition	to	Through	All.
16.	 Click	the	Positions	tab	and	click	on	the	top	face	of	the	second	feature.



17.	 Select	the	origin	point	of	the	3D	sketch.

18.	 Click	OK.

19.	 Create	a	through	hole	of	12	mm	diameter	on	the	first	feature.



20.	 Create	a	circular	pattern	of	the	hole.

21.	 Deactivate	the	Edit	Component	 icon	on	the	CommandManager.

Creating	the	Second	Component	of	the	Assembly
1.	 On	the	CommandManager,	click	Assembly	>	Insert	Components	>	New

Part .
2.	 Select	 the	 Front	 plane	 of	 the	 assembly	 from	 the	 FeatureManager	 Design

Tree.
3.	 Click	Exit	Sketch	on	the	CommandManager.
4.	 Click	Sketch	>	Sketch	 on	the	CommandManager.
5.	 Select	top	face	of	the	Base.



6.	 On	the	ribbon,	click	Sketch	>	Convert	Entities	 and	select	the	circular
edges	of	the	Base.

7.	 Click	OK	on	the	PropertyManager.
8.	 Draw	a	circle	of	120	mm	diameter.

9.	 Click	Exit	Sketch.
10.	 Click	 the	 outer	 circle,	 right-click,	 click	 the	 down-arrows	 located	 at	 the

bottom	of	the	shortcut	menu,	and	select	Contour	Select	Tool.



11.	 Click	in	the	region	enclosed	by	the	sketch.

12.	 Activate	the	Extruded	Boss/Base	 tool	and	extrude	the	sketch	up	to	40.

13.	 Exit	the	Edit	Component	 Mode.

Creating	the	third	Component	of	the	Assembly
1.	 On	the	CommandManager,	click	Assembly	>	Insert	Components	>	New

Part .
2.	 Select	 the	 Front	 plane	 of	 the	 assembly	 from	 the	 FeatureManager	 Design

Tree.
3.	 Draw	a	sketch,	as	shown	in	figure.



4.	 Click	Exit	Sketch.
5.	 Activate	the	Revolve	 tool	and	revolve	the	sketch.

6.	 Activate	the	Chamfer	 tool	and	chamfer	the	edges,	as	shown	in	figure.

7.	 Activate	the	Fillet	 tool	and	round	the	edges,	as	shown	in	figure.



8.	 Click	Edit	Component	 on	the	CommandManager.

					
Adding	Bolt	Connections	to	the	assembly
1.	 Click	the	Design	Library	 tab	on	the	left	side	of	the	graphics	window.
2.	 On	the	Design	Library	tab,	select	Toolbox	and	click	Add	in	now.
3.	 On	the	Design	Library	tab,	click	Toolbox	>	ANSI	Metric.
4.	 Under	the	ANSI	Metric	folder,	click	Bolts	and	Screws	>	Hex	Head.
5.	 Click	Heavy	 Hex	 Bolt-ANSI	 B18.2.3.6M	 and	 drag	 it	 into	 the	 graphics

window.

6.	 On	the	Configure	Component	PropertyManager,	set	the	bolt	properties	as
shown.



7.	 Click	the	Add	button	in	the	Part	Number	section	and	click	OK.
8.	 Click	OK	on	the	PropertyManager.	Another	instance	of	the	bolt	is	attached

to	the	pointer.

9.	 Click	Cancel	 to	stop	inserting	more	bolts.
10.	 On	the	Design	Library	tab,	click	Washer	>	Plain	Washers.
11.	 The	Regular	Flat	Washer	and	drag	it	into	the	graphics	window.
12.	 Set	 the	 washer	 size	 to	M12	 and	 click	 the	 Add	 button	 under	 the	 Part

Numbers	section	of	the	PropertyManager.
13.	 Click	OK	on	the	Part	Number	dialog.
14.	 Click	OK	and	Cancel.



15.	 On	the	Design	Library	tab,	under	ANSI	Metric,	click	Nuts	>	Hex	Nuts.
16.	 Click	and	drag	Hex	Heavy	Nut	into	the	graphics	window.
17.	 On	the	Configure	Component	PropertyManager,	set	 the	nut	properties	as

shown.

18.	 Click	 the	 Add	 button	 under	 the	 Part	 Numbers	 section	 of	 the
PropertyManager.

19.	 Click	OK	on	the	Part	Number	dialog.
20.	 Click	OK	and	Cancel.



21.	 On	the	CommandManager,	click	Assembly	>	Insert	Components	>	New
Assembly	 .	A	new	subassembly	is	inserted	into	the	assembly.

22.	 In	the	FeatureManager	Design	Tree,	click	and	drag	the	bolt,	nut	and	washer
into	the	subassembly.

23.	 Click	on	the	subassembly	and	select	Open	Subassembly.	The	Subassembly
is	opened	in	another	window.

24.	 On	the	CommandManager,	click	Assembly	>	Mate .
25.	 Click	the	Multiple	mate	mode	 icon	on	the	PropertyManager.
26.	 Click	on	the	cylindrical	face	of	the	bolt,	and	then	click	the	cylindrical	faces

of	the	washer	and	nut.	The	bolt	face	is	selected	as	a	common	mate	entity.



27.	 Click	Add/Finish	Mate .
28.	 Click	in	the	Entities	to	mate.
29.	 Select	the	flat	face	of	the	bolt.
30.	 Select	the	flat	face	of	washer.

31.	 Click	Flip	Mate	Alignment	 ,	and	then	click	OK	on	the	SOLIDWORKS
dialog.

32.	 Click	Add/Finish	Mate	 .

33.	 Likewise,	 align	 the	 end	 faces	 of	 the	 bolt	 and	 nut,	 and	 click	OK	 on	 the
PropertyManager.

34.	 Save	and	close	the	subassembly.
35.	 On	the	CommandManager,	click	Assembly	>	Mate .
36.	 Click	on	the	flat	face	for	the	washer	and	the	part	with	holes.



37.	 Click	the	Coincident	 icon,	and	click	Add/Finish	Mate .
38.	 Click	 the	 Cylindrical	 face	 of	 the	 bolt	 and	 circular	 edge	 of	 the	 hole	 as

shown.

39.	 Click	 the	Concentric 	 icon,	check	 the	Lock	Rotation	option,	and	click
Add/Finish	Mate .

40.	 Click	OK	on	the	PropertyManager.

Patterning	components	in	an	assembly
1.	 On	 the	CommandManager,	 click	Assembly	 >	Linear	 Pattern	 >	 Pattern

Driven	Component	Pattern .
2.	 Select	the	subassembly	from	the	FeatureManager	Design	Tree.



3.	 On	the	Pattern	Driven	PropertyManager,	click	in	the	Driving	Feature	or
Component	box.

4.	 Select	the	CircularPattern	of	the	first	component	from	the	FeatureManager
Design	Tree.

5.	 Click	OK	 on	the	PropertyManager.

6.	 Click	the	Save	 icon	on	the	Quick	Access	Toolbar.
7.	 Click	Save	All	on	the	Save	Modified	Documents	dialog.
8.	 Type	Ch8_tutorial1	in	the	File	name	box	and	click	Save.
9.	 Select	Save	internally(inside	the	assembly),	and	then	click	OK.

															
TUTORIAL	2
In	 this	 tutorial,	 you	 create	 a	 slider	 crank	 mechanism	 by	 applying	 advanced
mates.

														 		



1.	 Create	Slider	Crank	Assembly	folder.
2.	 Download	the	part	files	of	the	assembly	from	the	companion	website.	Next,

save	the	files	in	the	Slider	Crank	Assembly	folder.
3.	 Start	a	new	assembly	file.
4.	 Click	the	pin	 icon	on	the	Begin	Assembly	PropertyManager.	This	keeps

the	PropertyManager	active.
5.	 Click	the	Browse	button	on	the	PropertyManager.
6.	 Browse	 to	 the	Slider	Crank	Assembly	 folder,	 select	 all	 the	 components,

and	click	Open.
7.	 On	 the	 PropertyManager,	 in	 the	 Part/Assembly	 to	 Insert	 section,	 click

Base.

8.	 Click	in	the	assembly	window	to	position	the	Base	component.
9.	 Likewise,	position	the	other	components	in	the	assembly	window.
10.	 Click	OK	on	the	PropertyManager.

		
Creating	Smart	Mates
1.	 Press	the	Alt	key	and	click	on	the	face	of	the	slider,	as	shown.

2.	 Keep	the	Alt	key	pressed	and	drag	the	component	onto	the	face	of	the	Base
as	shown.



3.	 Release	 the	 left	 mouse	 button	 and	 notice	 that	 the	Mates	 toolbar	 appears
with	the	Coincident	 icon	selected.

4.	 Click	Add/Finish	Mate	 to	 create	 the	Coincident	mate	 between	 the	 two
faces.

5.	 Drag	the	slider	up	and	rotate	the	view	as	shown.

6.	 Click	the	face	of	the	slider.

													
7.	 Press	the	Alt	key	and	drag	the	slider	onto	the	face	of	the	Base	as	shown.



8.	 Click	the	Flip	Mate	Alignment	icon.
9.	 Click	Add/Finish	Mate.
10.	 Click	and	drag	the	slider	and	notice	that	it	can	intersect	with	the	base.

Creating	the	Limit	Mate
1.	 On	the	CommandManager,	click	Assembly	>	Mate .
2.	 On	 the	 PropertyManager,	 expand	 the	Advanced	Mates	 section	 and	 click

the	Distance	 icon.
3.	 Select	the	end	face	of	the	Base	as	shown.

4.	 Rotate	the	view	and	select	the	end	face	of	the	slider	as	shown.



5.	 Set	the	Distance	value	to	1	mm.
6.	 Set	the	Maximum	Value	and	Minimum	Value	to	459	and	1,	respectively.

7.	 Click	OK	twice	on	the	PropertyManager.
8.	 Click	and	drag	the	slider	and	notice	 that	 it	 is	constrained	between	the	end

faces	of	the	slot.



Creating	the	Slot	Mate
1.	 On	the	CommandManager,	click	Assembly	>	Mate .
2.	 On	the	PropertyManager,	expand	the	Mechanical	Mates	section	and	click

the	Slot	 icon.
3.	 Set	the	Constraint	to	Free.
4.	 Select	 the	 cylindrical	 face	 of	 the	 pin	 and	 flat	 face	 of	 the	 slider	 slot	 as

shown.

5.	 Click	OK	on	the	PropertyManager.
6.	 Expand	the	Standard	Mates	section	and	click	the	Coincident	 icon.
7.	 Select	the	flat	faces	of	the	pin	and	slider	as	shown.



8.	 Click	Add/Finish	Mate,	and	then	click	OK.
9.	 Click	and	drag	the	pin	and	notice	that	it	is	constrained	along	the	length	of

the	slot.

10.	 Press	the	Alt	key,	click	and	drag	the	upper	hole	of	the	crank.

11.	 Release	the	pointer	onto	the	cylindrical	of	the	pin.

12.	 Click	Add/Finish	Mate	to	add	the	Concentric	mate	between	the	hole	and
pin.

13.	 Use	the	Mate	command	to	add	the	Coincident	mate	between	the	end	face
of	the	pin	and	flat	face	of	the	crank.



14.	 Assemble	the	other	instance	of	the	pin	with	the	crank.

15.	 Assemble	the	pivot	with	the	pin.

16.	 Make	the	bottom	faces	of	the	pivot	and	base	coincident	to	each	other.

17.	 Make	the	Right	planes	of	the	pivot	and	base	coincident.



18.	 Click	and	drag	the	crank	and	notice	that	the	slider	moves	along	the	slot.
19.	 Save	and	close	the	assembly	and	its	parts.



Chapter	9:	Dimensions	and	Annotations

															
															

In	this	chapter,	you	will	learn	to

Create	Centerlines	and	Center	Marks
Edit	Hatch	Pattern
Apply	Dimensions
Place	Hole	callouts
Place	Datum	Feature
Place	Feature	control	frame
Place	Surface	symbol

															
TUTORIAL	1
In	this	tutorial,	you	create	the	drawing	shown	below.
	 	 	 	 	 	 	 	 	 	 	 	 	 	 	





1.	 Download	the	Adapter	Plate	file	from	the	Companion	website.
2.	 Open	a	new	drawing	file	using	the	Sample	template.
3.	 Click	Cancel	 on	the	Model	View	PropertyManager.
4.	 In	 the	 FeatureManager	 Design	 Tree,	 click	 the	 right	 mouse	 on

Sheet1	and	select	Properties.
5.	 On	the	Sheet	Properties	dialog,	select	Sheet/Format	Size	>	A4

(ANSI)	Landscape,	and	then	click	OK.

Creating	a	Model	View	with	Center	Marks

1.	 On	the	Quick	Access	Toolbar,	click	the	Options	 icon.
2.	 Click	the	Document	Properties	tab	on	the	dialog	and	select	Detailing	from

the	tree.
3.	 Check	the	options	in	the	Auto	insert	on	view	creation	section,	as	shown.

4.	 Select	Centerlines/Center	Marks	in	the	tree.
5.	 Under	 the	Slot	 center	marks	 section,	 select	Orient	 to	 slot	 and	 click	 the

icons,	as	shown.
6.	 Type-in	1	in	the	Size	box.
7.	 Check	 the	Scale	by	view	scale	option	 to	change	 the	gap	 in	 the	centreline

with	the	view	scale.



8.	 Click	OK.
9.	 Click	View	Layout	>	Model	View	 on	the	CommandManager.
10.	 Click	Browse	button	on	the	PropertyManager.
11.	 Browse	to	the	location	of	the	Adapter	Plate	and	double-click	on	it.
12.	 Set	the	Scale	to	Use	sheet	scale.
13.	 Set	the	Orientation	to	Front .
14.	 Set	the	Display	Style	to	Hidden	Line	Removed .
15.	 Place	the	front	view	on	the	left-side	on	the	drawing	sheet.
16.	 Click	OK .



17.	 Select	the	view	and	press	Delete.
18.	 Click	Yes	on	the	Confirm	Delete	dialog.

19.	 On	the	Quick	Access	Toolbar,	click	the	Options	 icon.
20.	 Click	the	Document	Properties	tab	on	the	dialog	and	select	Detailing	from

the	tree.
21.	 Uncheck	the	options	in	the	Auto	insert	on	view	creation	section	and	click

OK.
22.	 Create	the	front	view	and	notice	the	difference.

23.	 Click	View	Layout	>	Section	View	 on	the	CommandManager.
24.	 Select	the	center	point	of	the	front	view.
25.	 Click	OK.
26.	 Place	the	section	view	on	the	left	side.

														 																	
Creating	Centerlines	and	Center	Marks
1.	 Click	Annotation	>	Centerline 	on	the	CommandManager.
2.	 Select	the	parallel	lines	on	the	section	view,	as	shown	below.	The	centerline

is	created.



																					 		
															
3.	 Click	OK	 on	the	PropertyManager.
4.	 Click	Annotation	>	Center	Mark	 on	the	CommandManager.
5.	 On	the	PropertyManager,	under	Manual	Insert	Options	section,	click	the

Circular	Center	Mark	 	icon.
6.	 Select	the	outer	circles	of	the	counterbore	holes

7.	 Click	OK	 on	the	PropertyManager.



8.	 Activate	the	Center	Mark	 command.
9.	 On	 the	 PropertyManager,	 under	 the	Auto	 Insert	 section,	 check	 For	 all

slots.
10.	 Check	the	Circular	lines	option	and	uncheck	all	other	options.
11.	 Click	the	Arc	Slot	Ends 	icon.
12.	 Deactivate	the	Slot	Centers	 icon.
13.	 Select	the	front	view	and	click	OK.

Editing	the	Hatch	Pattern
1.	 Click	 on	 the	 hatch	 pattern	 of	 the	 section	 view.	 The	 Area	 Hatch/Fill

PropertyManager	appears.



2.	 Uncheck	the	Material	crosshatch	option.

																				
You	can	 select	 the	 required	hatch	pattern	 from	 the	Hatch	Pattern	 drop-down.
You	can	adjust	the	hatch	scale	and	angle.
																							
3.	 Click	OK .

															
Applying	Dimensions
1.	 Click	Annotation	>	Model	Items	 on	the	CommandManager.
2.	 Select	 Source	 >	 Entire	 model	 and	 uncheck	 the	 Import	 items	 into	 all

views	option	on	the	PropertyManager.
3.	 Click	on	the	front	view.
4.	 Click	OK.
5.	 Drag	and	arrange	the	dimensions	as	shown.



6.	 On	the	CommandManager,	click	Annotation	>	Hole	Callout .
7.	 Select	the	counterbore	hole	and	position	the	hole	callout	as	shown.

8.	 On	the	CommandManager,	click	Annotation	>	Smart	Dimension .
9.	 Select	the	center	marks	of	the	holes.
10.	 Move	the	pointer	in	the	region	between	the	holes	and	click	to	position	the

dimension.

						
11.	 Select	the	R1	dimension	and	type-in	the	text	in	the	Dimension	Text	box	on

the	PropertyManager.



12.	 Click	Close	 Dialog	 on	 the	 PropertyManager	 and	 position	 the	 dimension
properly.

13.	 Dimension	the	pitch	circle	diameter	of	the	counterbore	holes	as	shown.

	
14.	 On	the	CommandManager,	click	Annotation	>	Model	Items .
15.	 Select	 Source	 >	 Entire	 model	 and	 uncheck	 the	 Import	 items	 into	 all

views	option	on	the	PropertyManager.
16.	 Click	on	the	section	view.	Click	OK.



17.	 Click	and	drag	the	dimensions	as	shown.

18.	 Select	the	2	mm	dimension	and	notice	the	highlighted	origins.
19.	 Click	and	drag	the	endpoints	to	the	new	locations	as	shown.



20.	 Likewise,	modify	the	origins	of	other	dimensions	as	shown.

21.	 Select	the	lines,	as	shown.
22.	 Move	the	pointer	toward	right	and	click	to	place	the	dimension.



																					 		

23.	 Likewise,	add	the	counterbore	dimension.

24.	 Select	the	counterbore	dimension.
25.	 On	 the	 PropertyManager,	 under	 the	Tolerance/Precision	 section,	 set	 the

Tolerance	Type	to	Bilateral.
26.	 Set	the	tolerance	parameters	as	shown.



27.	 Click	Close	Dialog.

28.	 Likewise,	apply	the	other	dimensions,	as	shown	below.



																					 		
Placing	the	Datum	Feature
1.	 Click	Annotation	>	Datum	Feature	 on	the	CommandManager.
2.	 Select	the	extension	line	of	the	dimension,	as	shown	below.

				 		

3.	 On	the	PropertyManager,	click	the	Filled	Triangle	with	Shoulder	 icon.
4.	 Move	the	cursor	downward	and	click.
5.	 Likewise,	place	a	datum	feature	B,	as	shown	below.	Click	OK.



		

Placing	the	Feature	Control	Frame
1.	 Click	Annotation	>	Geometric	Tolerance	 on	the	CommandManager.
2.	 On	the	dialog,	select	Circular	Runout	from	the	Symbol	drop-down.

3.	 Type-in	0.02	and	A	in	the	Tolerance	1	and	Primary	boxes.
4.	 Select	a	point	on	the	line,	as	shown.
5.	 Move	the	cursor	horizontally	toward	right	and	click.
6.	 Click	OK.

															



7.	 Activate	the	Geometric	Tolerance	command.
8.	 On	the	dialog,	select	Circular	Runout	from	the	Symbol	drop-down.
9.	 Type-in	0.02	and	B	in	the	Tolerance	1	and	Primary	boxes.
10.	 Select	the	endpoint	of	the	edge	as	shown.
11.	 Move	 the	 pointer	 vertically	 up	 and	 click	 to	 position	 the	 feature	 control

frame.

12.	 Likewise,	add	another	feature	control	frame	and	click	OK.

Placing	the	Surface	Texture	Symbols
1.	 Click	Annotation	>	Surface	Symbol	 on	the	CommandManager.
2.	 Set	the	Maximum	Roughness	value	to	63	on	the	PropertyManager.		



3.	 Click	on	the	inner	cylindrical	face	of	the	hole,	as	shown	below.

																					 		

4.	 Click	OK.
5.	 Save	and	close	the	file.

															

															
																
															
															
															
															
															
															
															
															
															
															
															
															
															
															
															
															



															
															
															
															
															
															
															
															
															
															
															
															

	
	
	
	
	
	
	
Additional	Exercises

Exercise	1





Exercise	2
	



Exercise	3
	
	
Exercise	4



	
	
	
	
Exercise	5



	
	
Exercise	6



	





Table	of	Contents

Chapter	1:	Getting	Started
Starting	SOLIDWORKS
User	Interface

Quick	Access	Toolbar
Menu
CommandManager
Features	tab
Evaluate	tab
Sketch	tab
Assemble	tab
Drawing	Environment	tabs
Sheet	Metal	tab
FeatureManager	Design	Tree
Status	bar
View	(Heads	Up)	Toolbar
Shortcut	Menus
PropertyManager
Breadcrumbs

Mouse	Functions
Customizing	the	CommandManager,	Shortcut	Bars,	and	Menus

Chapter	2:	Modeling	Basics
Tutorial	1

Opening	a	New	Part	File
Starting	a	Sketch
Adding	Dimensions
Constructing	the	Base	Feature
Adding	an	Extruded	Feature
Adding	another	Extruded	Feature
Saving	the	Part

Tutorial	2
Opening	a	New	Part	File
Sketching	a	Revolve	Profile
Constructing	the	Revolved	Boss
Constructing	the	Cut	feature
Constructing	another	Cut	feature



Adding	a	Fillet
Saving	the	Part

Tutorial	3
Opening	a	New	Part	File
Constructing	the	Cylindrical	Feature
Constructing	Cut	feature
Saving	the	Part

Tutorial	4
Applying	Draft
Saving	the	Part

Chapter	3:	Assembly	Basics
Tutorial	1

Opening	a	New	Assembly	File
Inserting	the	Base	Component
Adding	the	second	component
Applying	Mates
Adding	the	Third	Component
Checking	the	Interference
Saving	the	Assembly
Starting	the	Main	assembly
Adding	Disc	to	the	Assembly
Placing	the	Subassembly
Adding	Constraints
Placing	the	second	instance	of	the	Subassembly
Saving	the	Assembly

Tutorial	2
Creating	the	Exploded	View

Creating	Explode	lines
Chapter	4:	Creating	Drawings

TUTORIAL	1
Opening	a	New	Drawing	File
Generating	the	Base	View
Creating	the	Section	View
Creating	the	Detailed	View
Creating	the	Centerline
Specifying	Dimension	Settings
Retrieving	Dimensions
Adding	additional	dimensions
Saving	the	Drawing



TUTORIAL	2
Creating	a	Custom	Sheet	Format
Starting	a	New	drawing
Generating	the	Drawing	Views

Tutorial	3
Creating	the	Isometric	View
Generating	the	Exploded	View
Creating	the	Bill	of	Materials
Creating	Balloons

Chapter	5:	Sketching
Creating	Rectangles
Creating	Polygons
Relations

Merge
Horizontal
Vertical
Tangent
Parallel
Perpendicular
Midpoint
Automatic	Relations
Deleting	Relations
Hiding	Relations
Sketch	Numeric	Input
Replace	Entity
Make	Path
Path	Length	Dimension
Convert	Entities
Midpoint	line,	Perimeter	Circle,	and	SketchXpert
Ellipses
Partial	Ellipse
Conic
Move	and	Rotate	Entities
Rotate	Entities
Copy	Entities
Scale	Entities
Trim	Entities
Extend	Entities
Offset	Entities



TUTORIAL	1
Sketch	Fillet
Sketch	Chamfer
Mirror	Entities
Stretch	Entities

Circular	Sketch	Pattern
3D	Sketch

Chapter	6:	Additional	Modeling	Tools
TUTORIAL	1

Constructing	the	Helix
Adding	the	Reference	Plane
Constructing	the	Sweep	feature

TUTORIAL	2
Constructing	a	Revolved	Cut
Constructing	a	Mirror	Feature

TUTORIAL	3
Creating	Sections	and	Guide	curves
Creating	another	section
Constructing	the	swept	feature
Constructing	the	Extruded	feature
Adding	Fillets
Shelling	the	Model
Adding	the	Indent	feature
Adding	Threads

TUTORIAL	4
Constructing	a	cylindrical	shell
Adding	a	Slot
Constructing	the	Axis
Constructing	the	Linear	pattern
Constructing	the	Circular	pattern

TUTORIAL	5
Constructing	the	first	feature
Constructing	the	Second	Feature
Constructing	the	third	feature
Inserting	Holes
Adding	Chamfers

TUTORIAL	6
Constructing	the	first	feature
Constructing	the	Extruded	cut



Making	the	Curve	Driven	Pattern
TUTORIAL	7

Start	a	new	part	file
Creating	the	second	feature
Adding	Cosmetic	Threads
Creating	Configurations	Table

TUTORIAL	8
Creating	the	First	Feature
Creating	the	Extruded	surface
Replacing	 the	 top	 face	 of	 the	 model	 with	 the
surface
Creating	a	Face	fillet
Creating	a	Variable	Radius	fillet
Shelling	the	Model
Creating	the	Mounting	Bosses
Creating	the	Vent	Feature

Chapter	7:	Sheet	metal	Modeling
TUTORIAL	1

Opening	a	New	File
Constructing	the	Base	Flange
Adding	an	Edge	flange
Constructing	the	Miter	Flange
Closing	the	Corners
Adding	Corner	Reliefs
Adding	a	Tab	feature
Adding	a	Jog
Unfolding	the	bends
Creating	Cuts	across	bends
Folding	the	Unfolded	bends
Performing	the	Forming	Operations
Making	the	Linear	Pattern
Adding	a	Hem
Adding	a	vent
Adding	Sheet	Metal	Gussets
Making	a	Fill	Pattern

Chapter	8:	Top-Down	Assembly
Creating	a	New	Assembly	File
Creating	a	component	in	the	Assembly
Creating	the	Second	Component	of	the	Assembly



Creating	the	third	Component	of	the	Assembly
Adding	Bolt	Connections	to	the	assembly
Patterning	components	in	an	assembly
TUTORIAL	2

Creating	Smart	Mates
Creating	the	Limit	Mate
Creating	the	Slot	Mate

Chapter	9:	Dimensions	and	Annotations
TUTORIAL	1

Creating	a	Model	View	with	Center	Marks
Creating	Centerlines	and	Center	Marks
Editing	the	Hatch	Pattern
Applying	Dimensions
Placing	the	Datum	Feature
Placing	the	Feature	Control	Frame
Placing	the	Surface	Texture	Symbols

Additional	Exercises
Exercise	1
Exercise	2
Exercise	3
Exercise	4
Exercise	5
Exercise	6


	Chapter 1: Getting Started
	Starting SOLIDWORKS
	User Interface
	Quick Access Toolbar
	Menu
	CommandManager
	Features tab
	Evaluate tab
	Sketch tab
	Assemble tab
	Drawing Environment tabs
	Sheet Metal tab
	FeatureManager Design Tree
	Status bar
	View (Heads Up) Toolbar
	Shortcut Menus
	PropertyManager
	Breadcrumbs

	Mouse Functions
	Customizing the CommandManager, Shortcut Bars, and Menus

	Chapter 2: Modeling Basics
	Tutorial 1
	Opening a New Part File
	Starting a Sketch
	Adding Dimensions
	Constructing the Base Feature
	Adding an Extruded Feature
	Adding another Extruded Feature
	Saving the Part

	Tutorial 2
	Opening a New Part File
	Sketching a Revolve Profile
	Constructing the Revolved Boss
	Constructing the Cut feature
	Constructing another Cut feature
	Adding a Fillet
	Saving the Part

	Tutorial 3
	Opening a New Part File
	Constructing the Cylindrical Feature
	Constructing Cut feature
	Saving the Part

	Tutorial 4
	Applying Draft
	Saving the Part


	Chapter 3: Assembly Basics
	Tutorial 1
	Opening a New Assembly File
	Inserting the Base Component
	Adding the second component
	Applying Mates
	Adding the Third Component
	Checking the Interference
	Saving the Assembly
	Starting the Main assembly
	Adding Disc to the Assembly
	Placing the Sub-assembly
	Adding Constraints
	Placing the second instance of the Sub-assembly
	Saving the Assembly

	Tutorial 2
	Creating the Exploded View
	Creating Explode lines


	Chapter 4: Creating Drawings
	TUTORIAL 1
	Opening a New Drawing File
	Generating the Base View
	Creating the Section View
	Creating the Detailed View
	Creating the Centerline
	Specifying Dimension Settings
	Retrieving Dimensions
	Adding additional dimensions
	Saving the Drawing

	TUTORIAL 2
	Creating a Custom Sheet Format
	Starting a New drawing
	Generating the Drawing Views

	Tutorial 3
	Creating the Isometric View
	Generating the Exploded View
	Creating the Bill of Materials
	Creating Balloons


	Chapter 5: Sketching
	Creating Rectangles
	Creating Polygons
	Relations
	Merge
	Horizontal
	Vertical
	Tangent
	Parallel
	Perpendicular
	Midpoint
	Automatic Relations
	Deleting Relations
	Hiding Relations
	Sketch Numeric Input
	Replace Entity
	Make Path
	Path Length Dimension
	Convert Entities
	Midpoint line, Perimeter Circle, and SketchXpert
	Ellipses
	Partial Ellipse
	Conic
	Move and Rotate Entities
	Rotate Entities
	Copy Entities
	Scale Entities
	Trim Entities
	Extend Entities
	Offset Entities
	TUTORIAL 1
	Sketch Fillet
	Sketch Chamfer
	Mirror Entities
	Stretch Entities

	Circular Sketch Pattern
	3D Sketch

	Chapter 6: Additional Modeling Tools
	TUTORIAL 1
	Constructing the Helix
	Adding the Reference Plane
	Constructing the Sweep feature

	TUTORIAL 2
	Constructing a Revolved Cut
	Constructing a Mirror Feature

	TUTORIAL 3
	Creating Sections and Guide curves
	Creating another section
	Constructing the swept feature
	Constructing the Extruded feature
	Adding Fillets
	Shelling the Model
	Adding the Indent feature
	Adding Threads

	TUTORIAL 4
	Constructing a cylindrical shell
	Adding a Slot
	Constructing the Axis
	Constructing the Linear pattern
	Constructing the Circular pattern

	TUTORIAL 5
	Constructing the first feature
	Constructing the Second Feature
	Constructing the third feature
	Inserting Holes
	Adding Chamfers

	TUTORIAL 6
	Constructing the first feature
	Constructing the Extruded cut
	Making the Curve Driven Pattern

	TUTORIAL 7
	Start a new part file
	Creating the second feature
	Adding Cosmetic Threads
	Creating Configurations Table

	TUTORIAL 8
	Creating the First Feature
	Creating the Extruded surface
	Replacing the top face of the model with the surface
	Creating a Face fillet
	Creating a Variable Radius fillet
	Shelling the Model
	Creating the Mounting Bosses
	Creating the Vent Feature


	Chapter 7: Sheet metal Modeling
	TUTORIAL 1
	Opening a New File
	Constructing the Base Flange
	Adding an Edge flange
	Constructing the Miter Flange
	Closing the Corners
	Adding Corner Reliefs
	Adding a Tab feature
	Adding a Jog
	Unfolding the bends
	Creating Cuts across bends
	Folding the Unfolded bends
	Performing the Forming Operations
	Making the Linear Pattern
	Adding a Hem
	Adding a vent
	Adding Sheet Metal Gussets
	Making a Fill Pattern


	Chapter 8: Top-Down Assembly
	Creating a New Assembly File
	Creating a component in the Assembly
	Creating the Second Component of the Assembly
	Creating the third Component of the Assembly
	Adding Bolt Connections to the assembly
	Patterning components in an assembly
	TUTORIAL 2
	Creating Smart Mates
	Creating the Limit Mate
	Creating the Slot Mate


	Chapter 9: Dimensions and Annotations
	TUTORIAL 1
	Creating a Model View with Center Marks
	Creating Centerlines and Center Marks
	Editing the Hatch Pattern
	Applying Dimensions
	Placing the Datum Feature
	Placing the Feature Control Frame
	Placing the Surface Texture Symbols

	Additional Exercises
	Exercise 1
	Exercise 2
	Exercise 3
	Exercise 4
	Exercise 5
	Exercise 6



